Bug 17942 - Cannot run dnsconf,apache config,sendmail config, etc. inside redhat 7.0
Cannot run dnsconf,apache config,sendmail config, etc. inside redhat 7.0
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
: 17982 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-09-30 03:30 EDT by Kenneth Yeh
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:47:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kenneth Yeh 2000-09-30 03:30:23 EDT
I installed redhat 7.0 professional server on my machine and installed the 
DNS as well as web server packages (apache, bind, bindutils, sendmail, 
etc) using the "server" install type.  However, when I run linuxconf after 
my install, I am unable to find the items "configure dns", "configure web 
server", or "configure sendmail" components in the Config->Networking-
>Server Tasks->(component) in the treemenu in linuxconf.  Is this a bug 
with linuxconf?  I tried running "dnsconf" from the command line and it 
tells me that either dnsconf is not installed or disabled and that 
Linuxconf cannot be renamed??  I did notice that the libraries for 
dnsconf, sendmail, and bind were installed so I'm assuming that this is 
probably a problem with linuxconf and not the other modules.  Anyone else 
experiencing this problem?  Any work-arounds or updates?
Comment 1 Alan Cox 2000-10-01 18:30:19 EDT
*** Bug 17982 has been marked as a duplicate of this bug. ***
Comment 2 Nalin Dahyabhai 2000-10-02 01:40:15 EDT
Some modules were disabled at compile-time to avoid problems which could not be
debugged for this release.  Others simply need to be enabled from
"Control/Control files and systems/Configure Linuxconf modules".
Comment 3 Kenneth Yeh 2000-10-02 01:48:01 EDT
So basically, I cannot run dnsconf, apache config in redhat 7.0 whereas I could in 6.2?  Will it be fixed so that I can run these configuration tools in 
linuxconf later?  If so, when?  I'm planning to use redhat 7.0 to be a DNS server and I require dnsconf to be able to configure my DNS...what 
work-arounds are there?  I tried to add these modules (dnsconf, apache, etc) into the "/etc/conf.linuxconf" file but it still won't let me configure it in 
linuxconf?  So this is how it's meant to be?  Basically, I cannot configure my web server or DNS server using linuxconf anymore?
Comment 4 Kenneth Yeh 2000-10-02 02:18:31 EDT
Dear Nalin,

How can this bug be closed and flagged as "NOTABUG"??  In 6.2, I can configure 
my domain name server and apache PERFECTLY whereas in 7.0, I cannot run either 
nor can I enable these modules manually.  How can this "not" be a bug??  
There's not even a workaround.  I don't see it documented anywhere in the 
Redhat manual that I will not be able to configure my domain name server or my 
web server using very basic and essential tools such as linuxconf.  Moreover, 
these features are working perfectly in 6.2.  

So basically, if you flag it "NOTABUG", does this mean that Redhat will not fix 
it and that this is the way that its going to be in 7.0?  


Comment 5 Trond Eivind Glomsrxd 2000-10-02 23:04:00 EDT
Many modules in linuxconf have been disabled because they can crash working
This is not a bug, it's a feature ("Look! We don't eat your file!"). Closing -
it was not working perfectly in 6.2, it worked for you.
Comment 6 Taylor Richards 2000-10-03 00:50:43 EDT
/usr/lib/linuxconf/modules/dnsconf.so.1.19.2 does not exist. It isn't included
in the linuxconf RPM and a rebuild from the SRPM fails to build dnsconf with
this error message:

-I../../dialog -I../../modapi -I../../userconf -I../../translate -I../../netconf
-I../../xconf -I../../dnsconf -I../../mailconf -I../../fstab -I../../diajava
-I../../tlmp/tlmplib -I../../tlmp/tlmpdia -I.. -DEXPORT= -DPUBLIC= -DPROTECTED=
-DPRIVATE= -DVIRTUAL= -DHAVE_NCURSES -I/usr/include/ncurses -I/usr/include/gd
-funsigned-char -g -Wall -D_GNU_SOURCE -c bind8.cc -o bind8.os
bind8.cc: In method `const char *BIND8_LEXPARSE::getarg1 ()':
bind8.cc:191: parse error before `not'
bind8.cc:193: parse error before `='
bind8.cc:202: parse error before `,'
bind8.cc:212: parse error before `,'
make: *** [bind8.os] Error 1

So basically dnsconf is not included with the RedHat 7 RPM of linuxconf.  Fix...
Comment 7 Kenneth Yeh 2000-10-03 04:06:19 EDT
Dear teg@redhat.com,

You stated:

"This is not a bug, it's a feature ("Look! We don't eat your file!"). Closing -
     it was not working perfectly in 6.2, it worked for you."

The bottom line is:

It should work...period!  How can you close this as "not a bug"?  It IS a BUG because it's a feature that is SUPPOSE to exist in Redhat 7 and has not 
been documented otherwise.  Either Redhat should tell people that "this cannot be done" in the online manuals or call this a BUG and fix it.
DNS Configurator is an ESSENTIAL tool because Redhat advertises and even gives the installer a choice to select the Domain Name Server and Web 
Server packages during the installation, yet these are useless without the configurators. 

Would you rather use DNSCONF to configure your domain name server or write your own domain zone files by hand???  



Comment 8 Matthieu Araman 2000-10-03 05:41:19 EDT

perhaps you should try the original linuxconf SRPM from
latest version is 1.21r5 and include some bugfixes made after the beta which
were not included in RH7.0
You will also have access to many more modules including dnsconf
Just be aware that the linuxconf from RH include some changes (see the SRPM from
RH)(like linuxconf in /bin or in /sbin..., permission changes...)

Matthieu Araman

PS : perhaps bugs in Linuxconf should be reported so they can be fixed

Comment 9 Stephen Samuel 2000-10-03 16:07:20 EDT
I think that it should be documented in the 7.0 release notes. This would allow
people to make an INFORMED choice -- both about (not)installing 7.0 (if dnsconf
is important to them) and about (not) continuing to use dnsconf (or at least
using RCS/CVS before doing configs, so that they can back out of a broken
Comment 10 ckulesa 2000-10-07 06:39:53 EDT
These module bugs are in Linuxconf, and really aren't Redhat's fault.  By
including them,
Redhat is essentially obliged to "support" these bugs.   The decision to leave
them out is understandable, IMHO. 

That they were supported in 6.2 and not in 7.0, without warning, is the issue of
Bait and switch. :)

But it's fixable. 

I have patched the Redhat Linuxconf SRPM with a simple fix for bind8.cc and
rebuilt it
with support for Redhat PPP, Apache, and DNSconf.    The old modules seem to
work with 
the Redhat 6.2 functionality, as far as I can tell.  You're welcome to the new
Linuxconf RPMs at:  

You may need to go into "Config --> Configure Linuxconf Modules" to re-enable
at Linuxconf startup the first time. 

And if DNSconf bites you, it's not my fault. :)  Works okay for me so far...

Comment 11 Need Real Name 2000-10-24 05:23:21 EDT
I compiled linuxconf-1.21r7 from source on RH7 on i586 and it works great now. 

Definitely needed to enable most modules in Configure Linuxconf Modules and 'ln -

s /sbin/linuxconf /bin/linuxconf'. Good luck.

Comment 12 Peter Ajamian 2001-03-31 04:07:17 EST
Never had a problem with dnsconf on 6.x myself (except for the occasional crash of Linuxconf, is it too much to ask for a program
that doesn't seg fault all the time?).  Anyways, I'd much appreciate getting dnsconf back in 7.0 and have to agree with the majority
of posters here that it really was not such a great idea to pull it.  You probably could have just as easily included it, left it disabled,
and marked it as experimental or unreliable somehow.  As it is I'll end up building it from the SRPM myself and making do.  Anyways,
My primary reason for this post is to add to the many people who are complaining in case someone is counting heads to determine
just how much of a priority this is.
Comment 13 Brent Fox 2002-06-05 12:22:45 EDT
Closing because we don't ship linuxconf anymore
Comment 14 Red Hat Bugzilla 2006-02-21 13:47:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.