Bug 179428 - (TBa09d7719) TBa09d7719 GUI_functions.py:89:get_pixbuf:GError: Couldn't recognize the image file format for file 'connection-ethernet.png'
TBa09d7719 GUI_functions.py:89:get_pixbuf:GError: Couldn't recognize the imag...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 05:49 EST by Elvin E. Ebora
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: pygtk2-2.10.1-5.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 22:48:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elvin E. Ebora 2006-01-31 05:49:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Unhandled exception occurs when opening the system-config-network GUI.

Version-Release number of selected component (if applicable):
system-config-network-1.3.30-2.1

How reproducible:
Always

Steps to Reproduce:
1. Go to KDE-Administration
2. Click on Network
3.
  

Actual Results:  Unhandled exception occurs

Expected Results:  Displays the system-config-network GUI

Additional info:

Component: system-config-network
Version: 1.3.30
Summary: TBa09d7719 GUI_functions.py:89:get_pixbuf:GError: Couldn't recognize the image file format for file '/usr/share/system-config-network/pixmaps/connection-ethernet.png'

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in main
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 124, in __init__
    widget.set_from_pixbuf(get_pixbuf("connection-ethernet.png"))
  File "/usr/share/system-config-network/netconfpkg/gui/GUI_functions.py", line 89, in get_pixbuf
    pixbuf = gtk.gdk.pixbuf_new_from_file(pixmap_file)
GError: Couldn't recognize the image file format for file '/usr/share/system-config-network/pixmaps/connection-ethernet.png'

Local variables in innermost frame:
pixmap_file: /usr/share/system-config-network/pixmaps/connection-ethernet.png
fn: connection-ethernet.png
Comment 1 Harald Hoyer 2006-01-31 06:14:37 EST
could you 
$ display /usr/share/system-config-network/pixmaps/connection-ethernet.png

??
Comment 2 Elvin E. Ebora 2006-01-31 19:40:33 EST
(In reply to comment #1)
> could you 
> $ display /usr/share/system-config-network/pixmaps/connection-ethernet.png
> 
> ??

Yes, I can display the said image (Im using konqueror). When I try to view its
file type, its a PNG Image while others on the said directory are in X Pixmap
Image except for some which are PNG Image as well like network.png,
neat-control-logo.png, nameresolution_alias.png, secure.png and
system-config-network-splash.png. I believe the other images which are in png
image format are all related to the system-config-network UI, right?

Hope this helps.
Comment 3 Harald Hoyer 2006-02-01 03:25:40 EST
Reassigning...

Has s.th. changed, that "gtk.gdk.pixbuf_new_from_file(file)" could not read png
files?
Comment 4 Elvin E. Ebora 2006-02-01 04:17:15 EST
(In reply to comment #2)
> (In reply to comment #1)
> > could you 
> > $ display /usr/share/system-config-network/pixmaps/connection-ethernet.png
> > 
> > ??
> 

After installing ImageMagick and the required fonts
(xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.0-1 and
xorg-x11-fonts-ISO8859-1-100dpi.noarch 0:7.0-1), I was able to diplay the image
on the terminal. But still the same exception occurs when opening
system-config-network UI. I have gtk2-2.8.11-1 and pygtk2-2.8.4-1 installed.

Comment 5 C. P. Price 2006-04-27 17:24:57 EDT
i get the same error. i also get it when i try to start yumex (and initially
filed a bug report for yumex, but had it killed because it was clear that it was
not a problem with yumex). i can view all the image files in question. i can
even write png files with gimp (although it bitches before saving in *any* image
format that it "does not support png". i have tried reinstalling fc5 from
scratch (actually, i had to do so, because the graphical login screen is also
png, and so could not login.) as a result of the last, i am dreading having a
situation where i have to log back in. i have a laptop on which i have also
installed fc5 (within days of installing on this box.) i have been doing daily
updates (yumex on laptop, yum.cron on the desktop). i think that the problem
started with one of the earliest updates. this is NOT an app error -- it is
something else.
Comment 6 C. P. Price 2006-04-27 17:30:00 EDT
ps. laptop ok, no png problems (implied by the fact that i am successfully using
yumex on laptop, as well as frequent logins). gtk2-2.8.17-1.fc5.1,
pygtk2-2.8.6-0.fc5.1, gtk+-1.2.10-50.
Comment 7 Matthew Barnes 2006-10-29 22:11:39 EST
Is this problem still seen in Fedora Core 6?

pygtk2-2.10.3-2.fc6
Comment 8 Elvin E. Ebora 2006-10-29 22:35:32 EST
Im using FC6 and pygtk2-2.10.1-5.fc6 and I'm not experiencing this problem anymore. 
Comment 9 Matthew Barnes 2006-10-29 22:48:16 EST
Okay, closing this bug then.  Thanks for responding, and feel free to reopen it
if you encounter this problem again.

Note You need to log in before you can comment on or make changes to this bug.