Bug 17943 - samba: src.rpm's rebuild overwrites /sbin/mount.smbfs
Summary: samba: src.rpm's rebuild overwrites /sbin/mount.smbfs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-30 07:58 UTC by giulioo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-30 07:58:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2000-09-30 07:58:07 UTC
samba-2.0.7/source/scripts/installbin.sh overwrites /sbin/mount.smbfs
+
samba really wants to be built as root
=
The system where you rebuild the src.rpm ends up with a /sbin/mount.smbfs 
that points to  /var/tmp/samba-root/usr/bin/smbmount

Since the spec file already takes care of creating a non-absolute link:

--- source/script/installbin.sh.orig    Tue Sep 26 21:28:20 2000
+++ source/script/installbin.sh Tue Sep 26 21:28:46 2000
@@ -33,9 +33,9 @@
  chmod $INSTALLPERMS $BINDIR/$p2
 
  # this is a special case, mount needs this in a specific location
- if [ $p2 = smbmount ]; then
-   ln -sf $BINDIR/$p2 /sbin/mount.smbfs
- fi
+ #if [ $p2 = smbmount ]; then
+ #  ln -sf $BINDIR/$p2 /sbin/mount.smbfs
+ #fi
 done

Comment 1 Bill Nottingham 2000-10-16 17:31:04 UTC
Fixed in samba-2.0.7-22, which should be in the next
rawhide release.


Note You need to log in before you can comment on or make changes to this bug.