Bug 179432 - Make downstream config changes in source instead of example configuration
Make downstream config changes in source instead of example configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 06:04 EST by Mark McLoughlin
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.0-0.beta2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 04:55:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dovecot-1.0.beta2-change-defaults.patch (2.87 KB, text/plain)
2006-01-31 06:04 EST, Mark McLoughlin
no flags Details

  None (edit)
Description Mark McLoughlin 2006-01-31 06:04:30 EST
The upstream dovecot-example.conf is essentially:

     ---
     $> grep -v '^ *\(#\|$\)' dovecot-example.conf
     protocol imap {
     }
     protocol pop3 {
     }
     auth default {
       mechanisms = plain
       passdb pam {
       }
       userdb passwd {
       }
       user = root
     }
     ---

And, because of the builtin defaults, that's essentially the same as:

     ---
     auth default {
       passdb pam {
       }
       userdb passwd {
       }
     }
     ---

What's nice about this is that people can start with the above simple config
file and make the few changes they need for their system.

However, Fedora's dovecot-example.conf is:

     ---
     $> grep -v '^ *#' /etc/dovecot.conf | grep -v ^$
     protocols = imap imaps pop3 pop3s
     listen = [::]
     ssl_listen = [::]
     ssl_cert_file = /etc/pki/dovecot/certs/dovecot.pem
     ssl_key_file = /etc/pki/dovecot/private/dovecot.pem
     mbox_read_locks = fcntl
     mbox_write_locks = fcntl
     protocol imap {
     }
     protocol pop3 {
     }
     auth default {
       mechanisms = plain
       passdb pam {
       }
       userdb passwd {
       }
       user = root
     }
     ---

It would be much nicer IMHO if we made these changes in the builtin defaults
rather than in the example configuration.

Attaching an untested patch to do this. Note:

  - No need to change default ssl_key_file and ssl_cert_file paths - you're 
    building with the correct --with-ssldir
  - No need to change "ssl_listen" as well as "listen" - "ssl_listen" defaults 
    to the value of "listen" if it's unset
  - No need to change "mbox_read_locks" - the upstream default is the same
Comment 1 Mark McLoughlin 2006-01-31 06:04:30 EST
Created attachment 123902 [details]
dovecot-1.0.beta2-change-defaults.patch
Comment 2 Petr Rockai 2006-01-31 07:52:15 EST
My problem with this approach is with people who have existing configuration       
files that point to different places. It is easier to find out if you have       
the right locations in the default configfile. I suppose your compromise to      
change the values to what we use now, but leave them commented out, as       
well as patch the source could be OK though. Still possibly a tad bit     
confusing, since the certificate changed location... Other than that looks    
fairly well, small buglet with ssl_key_file: s,certs,private,. I will think  
about it. 

Note You need to log in before you can comment on or make changes to this bug.