Bug 179436 - --noscripts not skipping post uninstall
--noscripts not skipping post uninstall
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 07:36 EST by Gene Czarcinski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 18:02:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simple Test Case (232 bytes, text/plain)
2006-01-31 10:57 EST, Paul Nasrat
no flags Details

  None (edit)
Description Gene Czarcinski 2006-01-31 07:36:30 EST
Description of problem:

Acording to the doc (man page), specifying "--noscripts" should cover all
scripts including the postinstall scripts.  This is not working.  Only when I
specified "--nopostun" was the post install script skipped.



Version:  rpm 4.4.2-13
Comment 1 Paul Nasrat 2006-01-31 10:57:09 EST
Created attachment 123915 [details]
Simple Test Case

The attached test case works for me as detailed below, please modify and supply
a reproducible test case and steps that I can examine.

[pauln@enki SPECS]$ sudo rpm -ivh ../RPMS/pypostun-1.0-1.i386.rpm
Preparing...		    ########################################### [100%]
   1:pypostun		    ########################################### [100%]
[pauln@enki SPECS]$ sudo rpm -e pypostun
hello
[pauln@enki SPECS]$ sudo rpm -ivh ../RPMS/pypostun-1.0-1.i386.rpm
Preparing...		    ########################################### [100%]
   1:pypostun		    ########################################### [100%]
[pauln@enki SPECS]$ sudo rpm --noscripts -e pypostun
[pauln@enki SPECS]$
Comment 2 Paul Nasrat 2006-01-31 11:00:05 EST
Code inspection seems correct too:

noscripts causes:
    case RPMCLI_POPT_NOSCRIPTS:
        ia->transFlags |= (_noTransScripts | _noTransTriggers);

rpmlib.h:
#define _noTransScripts         \
  ( RPMTRANS_FLAG_NOPRE |       \
    RPMTRANS_FLAG_NOPOST |      \
    RPMTRANS_FLAG_NOPREUN |     \
    RPMTRANS_FLAG_NOPOSTUN      \
  )
Comment 3 Gene Czarcinski 2006-01-31 18:02:42 EST
Maybe I was not quite awake this morning.  I would swear that it was not working
this morning but it sure works OK tonight.

I ran into a problem with eclipse packages hanging to to a problem in another
package which caused %post and %postun to hang.  In order to try cleaning things
up I had to rpm -e without the postun executing.

Anyway, I cannot reproduce the problem! [must have been a user error]

Note You need to log in before you can comment on or make changes to this bug.