This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 179452 - evolution-2.5.90-1 hangs
evolution-2.5.90-1 hangs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 179471 179486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 10:30 EST by Christian Schaller
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 11:40:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 329344 None None None Never

  None (edit)
Description Christian Schaller 2006-01-31 10:30:29 EST
After updating today Evolution just hangs on startup. Running evolution in gdb I
get this:

** (evolution:11277): WARNING **: Failed to connect to the D-BUS daemon: Failed
to connect to socket /tmp/dbus-hV8g9M9V5C: Connection refused

*** glibc detected *** /usr/bin/evolution: free(): invalid pointer: 0x08d0d5b8 ***
======= Backtrace: =========
/lib/libc.so.6[0xf31948]
/lib/libc.so.6(__libc_free+0x79)[0xf34e4d]
/usr/lib/libglib-2.0.so.0(g_free+0x2d)[0x60cc04]
/usr/lib/libgtkhtml-3.8.so.15(html_text_slave_get_glyph_items+0x12f)[0xc9a078]
/usr/lib/libgtkhtml-3.8.so.15[0xc9afec]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0xc7fbb4]
/usr/lib/libgtkhtml-3.8.so.15[0xc4fefa]
/usr/lib/libgtkhtml-3.8.so.15[0xc53245]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0xc7fbb4]
/usr/lib/libgtkhtml-3.8.so.15[0xc4fefa]
/usr/lib/libgtkhtml-3.8.so.15[0xc57246]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0xc7fbb4]
/usr/lib/libgtkhtml-3.8.so.15[0xc4fefa]
/usr/lib/libgtkhtml-3.8.so.15[0xc57246]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0xc7fbb4]
/usr/lib/libgtkhtml-3.8.so.15[0xc6ed75]
/usr/lib/libgtkhtml-3.8.so.15(html_engine_expose+0x7c)[0xc6f628]
/usr/lib/libgtkhtml-3.8.so.15[0xc48789]
/usr/lib/libgtk-x11-2.0.so.0[0x66a1673]
/usr/lib/libgobject-2.0.so.0[0x5ab6a5]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x11c)[0x5acdbd]
/usr/lib/libgobject-2.0.so.0[0x5be5c1]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6d1)[0x5bf2b3]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0x5bf6a5]
/usr/lib/libgtk-x11-2.0.so.0[0x677e9b0]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x4fc)[0x669ce82]
/usr/lib/libgdk-x11-2.0.so.0[0x432bbf]
/usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0x95)[0x432d66]
/usr/lib/libgtk-x11-2.0.so.0[0x6615b46]
/usr/lib/libglib-2.0.so.0[0x60442e]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x16e)[0x605c33]
/usr/lib/libglib-2.0.so.0[0x608c73]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a7)[0x60901c]
/usr/lib/libbonobo-2.so.0(bonobo_main+0x63)[0x68b5649]
/usr/bin/evolution[0x805d69f]
/lib/libc.so.6(__libc_start_main+0xdc)[0xee36b4]
/usr/bin/evolution[0x804fe31]
======= Memory map: ========
00101000-00108000 r-xp 00000000 fd:00 2427995    /usr/lib/libpopt.so.0.0.0
00108000-00109000 rwxp 00006000 fd:00 2427995    /usr/lib/libpopt.so.0.0.0
00111000-00125000 r-xp 00000000 fd:00 266998    
/usr/lib/evolution/2.6/libevolution-a11y.so.0.0.0
00125000-00126000 rwxp 00014000 fd:00 266998    
/usr/lib/evolution/2.6/libevolution-a11y.so.0.0.0
00126000-00179000 r-xp 00000000 fd:00 2437618   
/usr/lib/libcamel-provider-1.2.so.8.0.0
00179000-0017b000 rwxp 00052000 fd:00 2437618   
/usr/lib/libcamel-provider-1.2.so.8.0.0
0017b000-0017f000 r-xp 00000000 fd:00 2446435    /usr/lib/libplc4.so
0017f000-00180000 rwxp 00003000 fd:00 2446435    /usr/lib/libplc4.so
00180000-00184000 r-xp 00000000 fd:00 2440503    /usr/lib/libgthread-2.0.so.0.902.3
00184000-00185000 rwxp 00003000 fd:00 2440503    /usr/lib/libgthread-2.0.so.0.902.3
00185000-00186000 r-xp 00000000 fd:00 267025    
/usr/lib/evolution/2.6/plugins/liborg-gnome-default-mailer.so
00186000-00187000 rwxp 00000000 fd:00 267025    
/usr/lib/evolution/2.6/plugins/liborg-gnome-default-mailer.so
00187000-001d4000 r-xp 00000000 fd:00 2435376    /usr/lib/libcamel-1.2.so.0.0.0
001d4000-001d7000 rwxp 0004d000 fd:00 2435376    /usr/lib/libcamel-1.2.so.0.0.0
001d7000-001fe000 r-xp 00000000 fd:00 2442531   
/usr/lib/libedataserverui-1.2.so.6.1.0
001fe000-001ff000 rwxp 00027000 fd:00 2442531   
/usr/lib/libedataserverui-1.2.so.6.1.0
001ff000-00292000 r-xp 00000000 fd:00 2440212    /usr/lib/libecal-1.2.so.3.2.6
00292000-002a1000 rwxp 00092000 fd:00 2440212    /usr/lib/libecal-1.2.so.3.2.6
002a1000-002a4000 rwxp 002a1000 00:00 0
002a4000-002b8000 r-xp 00000000 fd:00 2445440   
/usr/lib/libgnome-2.so.0.1306.1002b8000-002b9000 rwxp 00014000 fd:00 2445440   
/usr/lib/libgnome-2.so.0.1306.1002b9000-002bb000 r-xp 00000000 fd:00 1476734   
/lib/libdl-2.3.90.so
002bb000-002bc000 r-xp 00001000 fd:00 1476734    /lib/libdl-2.3.90.so
002bc000-002bd000 rwxp 00002000 fd:00 1476734    /lib/libdl-2.3.90.so
002be000-002c2000 r-xp 00000000 fd:00 2428995    /usr/lib/libnotify.so.0.0.0
002c2000-002c3000 rwxp 00004000 fd:00 2428995    /usr/lib/libnotify.so.0.0.0
002c3000-002c7000 r-xp 00000000 fd:00 2439608    /usr/lib/libnm_glib.so.0.0.0
002c7000-002c8000 rwxp 00004000 fd:00 2439608    /usr/lib/libnm_glib.so.0.0.0
002c9000-002d1000 r-xp 00000000 fd:00 267012    
/usr/lib/evolution/2.6/libevolution-widgets-a11y.so.0.0.0
002d1000-002d2000 rwxp 00007000 fd:00 267012    
/usr/lib/evolution/2.6/libevolution-widgets-a11y.so.0.0.0
002d2000-002d4000 r-xp 00000000 fd:00 1475346    /lib/libcom_err.so.2.1
002d4000-002d5000 rwxp 00001000 fd:00 1475346    /lib/libcom_err.so.2.1
002d5000-002db000 r-xp 00000000 fd:00 2445496    /usr/lib/libgailutil.so.17.0.6
002db000-002dc000 rwxp 00005000 fd:00 2445496    /usr/lib/libgailutil.so.17.0.6

Program received signal SIGABRT, Aborted.
[Switching to Thread -1208211264 (LWP 11277)]
0x00970402 in __kernel_vsyscall ()
Comment 1 Dave Malcolm 2006-01-31 11:40:35 EST
Thanks for this bug report; should be fixed in tomorrow's rawhide
(dup of http://bugzilla.gnome.org/show_bug.cgi?id=329344 )
Comment 2 Dave Malcolm 2006-01-31 13:19:24 EST
*** Bug 179471 has been marked as a duplicate of this bug. ***
Comment 3 Dave Malcolm 2006-01-31 14:36:06 EST
*** Bug 179486 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.