Bug 179462 - Yum crashes with "/lib/libssl.so.5: undefined symbol: HMAC_CTX_set_flags"
Summary: Yum crashes with "/lib/libssl.so.5: undefined symbol: HMAC_CTX_set_flags"
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-31 16:17 UTC by Andrew
Modified: 2014-01-21 22:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 20:38:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew 2006-01-31 16:17:20 UTC
Description of problem:
After updating from FC3 to FC4, yum crashes with "/lib/libssl.so.5: undefined
symbol: HMAC_CTX_set_flags"

Version-Release number of selected component (if applicable):
2.4.1 and higher


How reproducible:
Every time.

Steps to Reproduce:
1. Run yum
2.
3.
  
Actual results:

 There was a problem importing one of the Python modules
 required to run yum. The error leading to this problem was:

    /lib/libssl.so.5: undefined symbol: HMAC_CTX_set_flags

 Please install a package which provides this module, or
 verify that the module is installed correctly.

 It's possible that the above module doesn't match the
 current version of Python, which is:
 2.4.1 (#1, May 16 2005, 15:19:29)
 [GCC 4.0.0 20050512 (Red Hat 4.0.0-5)]

Expected results:
yum executes.

Additional info:

After an update from FC3 to FC4, the FC4 and higher versions of yum no longer
execute.  The troubleshooting methods from Bug# 160373 also do not help.

This bug seems to be OpenSSL 0.9.7 related, as downloading the
openssl-0.9.8a-xxx.src.rpm (OpenSSL 0.9.8a) from the Development tree (Rawhide)
for FC5 and doing a rebuild on FC4 fixes the issue.

Note that you have to manually symlink /lib/libssl.so.5 to
/lib/libssl-0.9.8a-xxxxx.so as OpenSSL 0.9.7 cannot be removed due to dependency
issues.

Comment 1 Nalin Dahyabhai 2006-01-31 19:09:58 UTC
(In reply to comment #0)
> This bug seems to be OpenSSL 0.9.7 related, as downloading the
> openssl-0.9.8a-xxx.src.rpm (OpenSSL 0.9.8a) from the Development tree (Rawhide)
> for FC5 and doing a rebuild on FC4 fixes the issue.
> 
> Note that you have to manually symlink /lib/libssl.so.5 to
> /lib/libssl-0.9.8a-xxxxx.so as OpenSSL 0.9.7 cannot be removed due to dependency
> issues.

It sounds to me like this is where the problem lies -- OpenSSL 0.9.8 and 0.9.7
are not binary-compatible, and while creating the symlink may get past the
immediate error starting yum, it doesn't keep problems like this one from
cropping up.

Can you list the exact dependency error message you received?


Note You need to log in before you can comment on or make changes to this bug.