Bug 179484 - M-x php-mode in Emacs doesn't work
Summary: M-x php-mode in Emacs doesn't work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-31 19:15 UTC by Christopher Beland
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 21.4-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 03:57:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Beland 2006-01-31 19:15:27 UTC
Description of problem:
When I hit M-x php-mode in Emacs, the command is not recognized.  I would expect
that it would work in a similar fashion to M-x perl-mode, etc.

Version-Release number of selected component (if applicable):
emacs-common-21.4-5

How reproducible:
Always

Additional info:
I don't know if it's related, but the two mode definitions seems to be in
different directories:

/usr/share/emacs/21.4/lisp/progmodes/perl-mode.elc
/usr/share/emacs/site-lisp/php-mode.elc

-B.

Comment 1 Jens Petersen 2006-02-03 07:59:57 UTC
Thanks for the report - the autoload in php-mode-init.el was incomplete.

You can add:

;;; php-mode
(autoload 'php-mode "php-mode" "Major mode for editing PHP code." t)

to your .emacs file say to workaround it for now.

Fix should be in next build emacs-21.4-12 in FC devel.

Comment 2 Jens Petersen 2006-03-28 03:57:27 UTC
Fix should be in FC5.

Comment 3 Christopher Beland 2007-08-26 21:12:16 UTC
Confirmed to be fixed, at least as of Fedora 7.


Note You need to log in before you can comment on or make changes to this bug.