Bug 179486 - Evolutions hangs with certain e-mails
Evolutions hangs with certain e-mails
Status: CLOSED DUPLICATE of bug 179452
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 14:28 EST by José Salgado
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 14:36:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one of the mails who hangs evolution (5.27 KB, text/plain)
2006-01-31 14:28 EST, José Salgado
no flags Details

  None (edit)
Description José Salgado 2006-01-31 14:28:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
With certain e-mails (new or old) evolutions hangs.

Version-Release number of selected component (if applicable):
evolution-2.5.90-1

How reproducible:
Always

Steps to Reproduce:
1.Open evolution
2.Go to read any mail
3.Evolution crash
  

Actual Results:  I must kill the application.


Expected Results:  That I can read the mail :9

Additional info:

From console I have this log:
*** glibc detected *** evolution: free(): invalid pointer: 0x08c33f38 ***
======= Backtrace: =========
/lib/libc.so.6[0x7457948]
/lib/libc.so.6(__libc_free+0x79)[0x745ae4d]
/usr/lib/libglib-2.0.so.0(g_free+0x2d)[0xb7cc04]
/usr/lib/libgtkhtml-3.8.so.15(html_text_slave_get_glyph_items+0x12f)[0x6f4078]
/usr/lib/libgtkhtml-3.8.so.15[0x6f4fec]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6a9efa]
/usr/lib/libgtkhtml-3.8.so.15[0x6ad245]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6a9efa]
/usr/lib/libgtkhtml-3.8.so.15[0x6b1246]
/usr/lib/libgtkhtml-3.8.so.15[0x6ec41b]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6e98e5]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6a9efa]
/usr/lib/libgtkhtml-3.8.so.15[0x6ad245]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6a9efa]
/usr/lib/libgtkhtml-3.8.so.15[0x6b1246]
/usr/lib/libgtkhtml-3.8.so.15[0x6ec41b]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6e98e5]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6a9efa]
/usr/lib/libgtkhtml-3.8.so.15[0x6ad245]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6a9efa]
/usr/lib/libgtkhtml-3.8.so.15[0x6b1246]
/usr/lib/libgtkhtml-3.8.so.15(html_object_draw+0x42)[0x6d9bb4]
/usr/lib/libgtkhtml-3.8.so.15[0x6c8d75]
/usr/lib/libgtkhtml-3.8.so.15(html_engine_expose+0x7c)[0x6c9628]
/usr/lib/libgtkhtml-3.8.so.15[0x6a2789]
/usr/lib/libgtk-x11-2.0.so.0[0x10b9673]
/usr/lib/libgobject-2.0.so.0[0x96c6a5]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x11c)[0x96ddbd]
/usr/lib/libgobject-2.0.so.0[0x97f5c1]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6d1)[0x9802b3]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0x9806a5]
/usr/lib/libgtk-x11-2.0.so.0[0x11969b0]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x4fc)[0x10b4e82]
/usr/lib/libgdk-x11-2.0.so.0[0x884bbf]
/usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0x95)[0x884d66]
/usr/lib/libgdk-x11-2.0.so.0[0x884ddd]
/usr/lib/libglib-2.0.so.0[0xb7442e]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x16e)[0xb75c33]
/usr/lib/libglib-2.0.so.0[0xb78c73]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a7)[0xb7901c]
/usr/lib/libbonobo-2.so.0(bonobo_main+0x63)[0x763649]
evolution[0x805d69f]
/lib/libc.so.6(__libc_start_main+0xdc)[0x74096b4]
evolution[0x804fe31]
======= Memory map: ========
00111000-00115000 r-xp 00000000 fd:00 15441381   /usr/lib/libnotify.so.0.0.0
00115000-00116000 rwxp 00004000 fd:00 15441381   /usr/lib/libnotify.so.0.0.0
00116000-0011a000 r-xp 00000000 fd:00 15438991   /usr/lib/libplc4.so
0011a000-0011b000 rwxp 00003000 fd:00 15438991   /usr/lib/libplc4.so
0011b000-00126000 r-xp 00000000 fd:00 15440557   /usr/lib/libgnome-keyring.so.0. 0.1
00126000-00127000 rwxp 0000a000 fd:00 15440557   /usr/lib/libgnome-keyring.so.0. 0.1
00127000-0013b000 r-xp 00000000 fd:00 15444162   /usr/lib/libgnome-2.so.0.1306.1
0013b000-0013c000 rwxp 00014000 fd:00 15444162   /usr/lib/libgnome-2.so.0.1306.1
0013c000-00144000 r-xp 00000000 fd:00 15437174   /usr/lib/libpangocairo-1.0.so.0 .1101.2
00144000-00145000 rwxp 00007000 fd:00 15437174   /usr/lib/libpangocairo-1.0.so.0 .1101.2
00145000-00148000 r-xp 00000000 fd:00 15437021   /usr/lib/libgmodule-2.0.so.0.90 2.3
00148000-00149000 rwxp 00002000 fd:00 15437021   /usr/lib/libgmodule-2.0.so.0.90 2.3
00149000-0014b000 r-xp 00000000 fd:00 14385183   /lib/libdl-2.3.90.so
0014b000-0014c000 r-xp 00001000 fd:00 14385183   /lib/libdl-2.3.90.so
0014c000-0014d000 rwxp 00002000 fd:00 14385183   /lib/libdl-2.3.90.so
0014e000-00152000 r-xp 00000000 fd:00 16450211   /usr/lib/evolution/2.6/libetime zonedialog.so.0.0.0
00152000-00153000 rwxp 00003000 fd:00 16450211   /usr/lib/evolution/2.6/libetime zonedialog.so.0.0.0
00153000-001a00
Comment 1 José Salgado 2006-01-31 14:28:58 EST
Created attachment 123933 [details]
one of the mails who hangs evolution
Comment 2 Dave Malcolm 2006-01-31 14:36:04 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 179452 ***

Note You need to log in before you can comment on or make changes to this bug.