Bug 179532 - internal error: Segmentation fault
Summary: internal error: Segmentation fault
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: java-1.4.2-gcj-compat   
(Show other bugs)
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Keywords:
: 179533 179555 179556 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-01 05:37 UTC by Ashish
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 20:12:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ashish 2006-02-01 05:37:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
src/com/sun/cldc/io/ConsoleOutputStream.java:133: warning: Discouraged form of returned type specification.
   <<file too short - unexpected EOF>>
                                             ^
src/java/lang/Object.java: In class `java.lang.Object':
src/java/lang/Object.java: In constructor `()':
src/java/lang/Object.java:1: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
It is an error occured during compiling j2me for arm linux.
1. At first we calls a Makefile
2. Makefile compiles the java file using javac and stores in a folder called classes
3. Call makefile directly at DIR/built/linux/
DIR=location of j2me installation. (Here it is /root/j2me_cldc/)
  

Actual Results:  makefile executes successfully hence creating the kvm for arm processor...

Expected Results:  The makefile is generating the following errors...


--- cut ---

src/com/sun/cldc/io/ConsoleOutputStream.java:133: warning: Discouraged form of returned type specification.
   <<file too short - unexpected EOF>>
                                             ^
src/java/lang/Object.java: In class `java.lang.Object':
src/java/lang/Object.java: In constructor `()':
src/java/lang/Object.java:1: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

--- cut ---

Additional info:

i know that this is a j2me issue. But the error Segmentation fault is a real java issue. 

--- cut ---
public boolean equals(Object obj) {
        return (this == obj);
}
--- cut ---

I beleive, this part of the code is generating the error.

Comment 1 Thomas Fitzsimmons 2006-06-30 20:09:26 UTC
*** Bug 179556 has been marked as a duplicate of this bug. ***

Comment 2 Thomas Fitzsimmons 2006-06-30 20:10:11 UTC
*** Bug 179555 has been marked as a duplicate of this bug. ***

Comment 3 Thomas Fitzsimmons 2006-06-30 20:12:10 UTC
*** Bug 179533 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.