Bug 179548 - CORE2(x86_64) (rhr2-2.0-1 version) test output.log error message e.g. "Failed tests: + fgrep FAIL /var/log/rhr/tests/CORE2/0/ltpstress.log" if rsh service not running.
CORE2(x86_64) (rhr2-2.0-1 version) test output.log error message e.g. "Failed...
Status: CLOSED ERRATA
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2 (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Will Woods
Will Woods
https://bugzilla.redhat.com/bugzilla/...
:
: 183400 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 06:10 EST by S. Lele
Modified: 2007-04-18 13:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0278
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 09:38:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description S. Lele 2006-02-01 06:10:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
With ref. bz# 175733 , when CORE2 test(x86_64) (rhr2-2.0-1 version) was run with with Intel(R) Pentium(R) D CPU 2.80GHz, Cache: 1024 KB and 8GB RAM, in hardware certification interface, the test result is shown as OK where as CORE2 test output.log file gives messages as follows:
"+ local ltplog=/var/log/rhr/tests/CORE2/0/ltpstress.log
+ cd /usr/lib/ltp/testscripts
+ ./ltpstress.sh -t 4 -S -l /var/log/rhr/tests/CORE2/0/ltpstress.log
Error: 'rsh' daemon not active on this machine.
fgrep PASS $ltplog|wc -l
++ fgrep PASS /var/log/rhr/tests/CORE2/0/ltpstress.log
fgrep: /var/log/rhr/tests/CORE2/0/ltpstress.log: No such file or directory
++ wc -l
+ local 'pass=      0'
fgrep FAIL $ltplog|wc -l
++ fgrep FAIL /var/log/rhr/tests/CORE2/0/ltpstress.log
fgrep: /var/log/rhr/tests/CORE2/0/ltpstress.log: No such file or directory"

As per advise from Will Woods, this problem may occur if rsh service is not running before CORE2 test. To resolve this problem, rsh service needs to be running by giving following command:
chkconfig rsh on 
and then run CORE2 test.

Version-Release number of selected component (if applicable):
rhr2-2.0-1

How reproducible:
Always

Steps to Reproduce:
1.rsh service should not be running before start of CORE2 test (rhr2-2.0-1 version).
2.run CORE2 test with Intel(R) Pentium(R) D CPU 2.80GHz, Cache: 1024 KB and 8GB RAM
3.
  

Actual Results:  CORE2 test result is passed in hardware certification interface but the output.log file gives message as follows:

"+ local ltplog=/var/log/rhr/tests/CORE2/0/ltpstress.log
+ cd /usr/lib/ltp/testscripts
+ ./ltpstress.sh -t 4 -S -l /var/log/rhr/tests/CORE2/0/ltpstress.log
Error: 'rsh' daemon not active on this machine.
fgrep PASS $ltplog|wc -l
++ fgrep PASS /var/log/rhr/tests/CORE2/0/ltpstress.log
fgrep: /var/log/rhr/tests/CORE2/0/ltpstress.log: No such file or directory
++ wc -l
+ local 'pass=      0'
fgrep FAIL $ltplog|wc -l
++ fgrep FAIL /var/log/rhr/tests/CORE2/0/ltpstress.log
fgrep: /var/log/rhr/tests/CORE2/0/ltpstress.log: No such file or directory"

Expected Results:  CORE2 test run normally without any above mentioned error messages.

Additional info:
Comment 1 Will Woods 2006-02-14 16:47:10 EST
rsh is now started before running LTP tests.

This change has been checked into CVS and will be made available via an errata
package soon.
Comment 2 Will Woods 2006-02-28 17:36:19 EST
*** Bug 183400 has been marked as a duplicate of this bug. ***
Comment 5 Red Hat Bugzilla 2006-05-08 09:38:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0284.html
Comment 6 Red Hat Bugzilla 2006-05-08 09:38:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0278.html

Note You need to log in before you can comment on or make changes to this bug.