Bug 179555 - Internal Error: Segmentation Fault
Internal Error: Segmentation Fault
Status: CLOSED DUPLICATE of bug 179532
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: java-1.4.2-gcj-compat (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 07:54 EST by Ashish
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 16:10:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish 2006-02-01 07:54:29 EST
Description of problem:
src/com/sun/cldc/io/ConsoleOutputStream.java:133: warning: Discouraged form of 
returned type specification.
   <<file too short - unexpected EOF>>
                                             ^
src/java/lang/Object.java: In class `java.lang.Object':
src/java/lang/Object.java: In constructor `()':
src/java/lang/Object.java:1: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
It is an error occured during compiling j2me for arm linux.
1. At first we calls a Makefile
2. Makefile compiles the java file using javac and stores in a folder called 
classes
3. Call makefile directly at DIR/built/linux/
DIR=location of j2me installation. (Here it is /root/j2me_cldc/)
  

Actual Results:  makefile executes successfully hence creating the kvm for arm 
processor...

Expected Results:  The makefile is generating the following errors...


--- cut ---

src/com/sun/cldc/io/ConsoleOutputStream.java:133: warning: Discouraged form of 
returned type specification.
   <<file too short - unexpected EOF>>
                                             ^
src/java/lang/Object.java: In class `java.lang.Object':
src/java/lang/Object.java: In constructor `()':
src/java/lang/Object.java:1: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

--- cut ---

Additional info:

i know that this is a j2me issue. But the error Segmentation fault is a real 
java issue. 

--- cut ---
public boolean equals(Object obj) {
        return (this == obj);
}
--- cut ---

I beleive, this part of the code is generating the error.
Comment 1 Thomas Fitzsimmons 2006-06-30 16:10:09 EDT

*** This bug has been marked as a duplicate of 179532 ***

Note You need to log in before you can comment on or make changes to this bug.