Bug 179574 - pop3 uidl format issues
pop3 uidl format issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 10:08 EST by Paul Dickson
Modified: 2014-01-21 17:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 04:47:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Dickson 2006-02-01 10:08:57 EST
Description of problem:
Because plaintext LOGINs are disabled now by default, I thought I'd try SSL. 
But sylpheed is giving me these errors:

** LibSylph-WARNING: SSL_read() returned error 5, ret = 0

** LibSylph-WARNING: sock_read: received EOF



Version-Release number of selected component (if applicable):
dovecot-1.0-0.beta2.2

How reproducible:
Always

Steps to Reproduce:
1. Install dovecot
2. Set sylpheed to use SSL or STARTTLS
3. Fetch E-mail
  
Actual results:
* Connecting to POP3 server: red.pwd.internal...
** LibSylph-WARNING: red.pwd.internal: SSL certificate verify failed (18: self
signed certificate)

[08:05:08] POP3< +OK Dovecot ready.
[08:05:08] POP3> USER dickson
[08:05:08] POP3< +OK
[08:05:08] POP3> PASS ********
[08:05:08] POP3< +OK Logged in.
[08:05:08] POP3> STAT
** LibSylph-WARNING: SSL_read() returned error 5, ret = 0

** LibSylph-WARNING: sock_read: received EOF

** LibSylph-WARNING: [08:05:08] Connection closed by the remote host.

** Connection closed by the remote host.


Expected results:
E-mail being downloaded

Additional info:
I first had this problem with sylpheed-2.1.6, but I downloaded and compiled
2.2.0beta7 to verify that it wasn't just that version.  Both systems are running
the latest version of devel (only this very latest version of dovecot became
available while I was debugging, but it too has the problem).

Is there another MUA that supports SSL that I can test against dovecot?
Comment 1 Paul Dickson 2006-02-01 10:19:37 EST
Ok, this might not be an SSL problem.  Setting disable_plaintext_auth = no, I get:

* Connecting to POP3 server: red.pwd.internal...
[08:20:33] POP3< +OK Dovecot ready.
[08:20:33] POP3> USER dickson
[08:20:33] POP3< +OK
[08:20:33] POP3> PASS ********
[08:20:33] POP3< +OK Logged in.
[08:20:33] POP3> STAT
** LibSylph-WARNING: sock_read: received EOF

** LibSylph-WARNING: [08:20:33] Connection closed by the remote host.

** Connection closed by the remote host.
Comment 2 Paul Dickson 2006-02-01 10:28:24 EST
maillog (on server running dovecot) is getting:
   child 3363 (pop3) returned error 89
Comment 3 Petr Rockai 2006-02-01 11:01:34 EST
the error (here) also says: 
pop3(dovetest): pop3_uidl_format setting is missing from config file 
 
can you please try adding this to your dovecot.conf and see if it fixes the 
problem? if yes, i'll see if i can add a default for this setting into the 
configfile 
Comment 4 Paul Dickson 2006-02-01 11:39:27 EST
Setting it to the new default value (%08Xu%08Xv) resolved this issue, both for
plain text and SSL.
Comment 5 Petr Rockai 2006-02-09 06:15:11 EST
To relnotes: Could we please have something in the spirit of the following 
text added to FC5 release notes? I don't know of a technical solution to this 
problem that would be plausible, so probably documenting this behaviour in 
relnotes is the best compromise. 
 
The default setting of pop3_uidl_format for dovecot pop3 server changed from 
previous versions of Fedora Core. If you already use dovecot pop3, your 
setting may be different than the new default, so please make sure to check 
this and change it accordingly. If the uidl format changes in upgrade, all 
mails that are kept on the server by pop3 clients will be re-downloaded. This 
may or may not be a problem depending on situation. 
Comment 6 Karsten Wade 2006-02-09 12:33:56 EST
http://fedoraproject.org/wiki/Docs/Beats/PackageNotes contains a note about
dovecot that seems to address this situation and others.

If this particular change is worth highlighting above others, for example
because it is more likely to happen to Fedora users, than please include it.

You can edit the wiki directly (let me know if you don't have permissions and
I'll add you to EditGroup), or let us know here if you think this more detailed
entry is necessary.

Thanks for thinking of the release notes!
Comment 7 Petr Rockai 2006-03-14 04:47:34 EST
I suppose what is there is sufficient. Closing this bug. 

Note You need to log in before you can comment on or make changes to this bug.