Bug 17959 - Control center does not detect that sawfish is running.
Control center does not detect that sawfish is running.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: control-center (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 11:59 EDT by Need Real Name
Modified: 2013-04-02 00:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-26 22:32:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-30 11:59:21 EDT
When running the default gnome setup that comes with RedHat 7.0, I can open
the Gnome Control Center, but when I select any of the configuration
categories connected to the Sawfish tree, the right side of the window just
displays "[Sawfish isn't running]".  A quick check with ps shows that
sawfish is indeed running and is my window manager.  Additionally, if I use
the middle button on the root window to pop up the Sawfish menu, selecting
"Focus" in the "Customize" menu does not do anything.
Comment 1 Rick Richardson 2000-10-23 13:45:37 EDT
I have this problem on a machine with a fresh install of 7.0.
I do not have this problem on a machine that did an upgrade install of 7.0
Don't know if that helps any, but thats the situation here.

Is there any workaround available?  How does the control center
detect if sawfish is running.
Comment 2 Need Real Name 2000-10-26 22:32:37 EDT
This problem only occurs on initial setup.  If you choose a different window
manager and run it, you can then choose sawfish and it will be recognized.
Comment 3 Elliot Lee 2001-01-31 18:55:13 EST
Can't reproduce either problem with 7.0, worksforme
Comment 4 Rick Richardson 2001-03-18 06:24:28 EST
Argh!  My home machine which had been working fine with Sawfish for several
months and which did not exhibit this problem (like my work machine does), is
now doing this as well.

There is most definitely a problem in this area, and if you do a google search
you'll see that other people are reporting this problem as well.

The only known workaround that I have been able to find is to switch to
Enlightenment.

-Rick
Comment 5 Jim Collins 2001-08-15 18:18:20 EDT
Folks who are seeing this should check that/tmp/.sawmill-<their username> and
/tmp/.sawmill-<their username>/<host>:<display> are owned by <their username>
and have perms 700.

I started seeing "sawfish is not running" in gnomecc after changing UID and
starting X with the "-nolisten tcp" flag. With strace I observed gnomecc attempt
to open local socket using /tmp/.sawmill-<username>/<host>:<display> which fails
due to perms/ownership of /tmp/.sawmill-<username>. It then tried PF_INET socket
to port 6000 which fails because X is not listening (starting X with -nolisten
tcp).

Note You need to log in before you can comment on or make changes to this bug.