Bug 179661 - STORAGE2 fails when testing cciss devices
Summary: STORAGE2 fails when testing cciss devices
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2 (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Will Woods
QA Contact: Will Woods
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-01 22:42 UTC by Will Woods
Modified: 2007-04-18 17:36 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0278
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 13:39:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0278 normal SHIPPED_LIVE rhr2 bug fix update 2006-05-08 04:00:00 UTC
Red Hat Product Errata RHBA-2006:0284 normal SHIPPED_LIVE rhr2 bug fix update 2006-05-08 04:00:00 UTC

Description Will Woods 2006-02-01 22:42:40 UTC
when testing a cciss device, the STORAGE2 test will die when it tries to create
a temporary file. 

Normally STORAGE2 creates a temporary directory with the name of the device,
e.g. /tmp/sda.XXXXXXX. Since the device is named (for example) cciss/c0d0p0, the
tempfile would be named /tmp/cciss/c0d0p0. But since /tmp/cciss/ does not exist,
mktemp fails, causing STORAGE2 to fail.

Comment 1 Will Woods 2006-02-01 22:45:32 UTC
This bug is present in rhr2-2.0-1, but fixed in CVS. I need to get confirmation
of the fix from the bug reporter (or just anyone with some cciss hardware). Once
that's done, an erratum will be made available as soon as possible.

Comment 4 Red Hat Bugzilla 2006-05-08 13:39:09 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0284.html


Comment 5 Red Hat Bugzilla 2006-05-08 13:39:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0278.html



Note You need to log in before you can comment on or make changes to this bug.