Bug 179679 - Text based installer chrashes with python free(): invalid pointer
Text based installer chrashes with python free(): invalid pointer
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 19:09 EST by Place Holder
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 16:15:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Place Holder 2006-02-01 19:09:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I was trying to install Fedora Core 5 Test 2 from CD on a headless box using the COM1 console in text mode.

boot: linux console=ttyS0,9600                                                  

I had entered all basic information, except that I had spent some time customizing the boot partition to try and get /home in a separate partition.  I selected most packages groups, except I didn't take many of the server ones.  During the package dependency checking the software crashed:

      âââââââââââââââââââââââ⤠Dependency Check âââââââââââââââââââââââââ      
      â                                                                 â       
      â Checking dependencies in packages selected for installation...  â       
      â                                                                 â       
      â                                5%                             *** glibc detected *** /usr/bin/python: free(): invalid pointer: 0x0c5f8b30 ***                              â       
      âââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââ       


Version-Release number of selected component (if applicable):
Trying to install FC5 Test 2

How reproducible:
Didn't try

Steps to Reproduce:
1. Boot from CD, start the installation
2. Answer all prompts (played with partitioning)
3. Select packages (I selected most non-server packages)
4. Wait for dependency checking to crash

Actual Results:  1-3 as expected
4. Crash, as documented

Expected Results:  The installation should have proceeded.

Additional info:

Marking this as a high priority bug as I will be unable to install the system until it is fixed.
Comment 1 Place Holder 2006-02-01 19:24:02 EST
I just tried again a second time, without doing any of the partition changes,
and doing what I though were the same package selections as the time before, and
this time it proceeded to install.
Comment 2 Rahul Sundaram 2006-02-20 06:26:57 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Jeremy Katz 2006-02-20 15:15:04 EST
I haven't seen this at all on any of my test installs.  Is it reproducible for
you at all?
Comment 4 Place Holder 2006-02-22 19:03:37 EST
I just tried a reinstall on FC5Test3 with a modified partition, and could not 
reproduce the problem, but I noted something that might possibly explain the 
previous occurance.  I think I might have set my / partition to be too small 
last time.  This time I only selected 4G and I note the package set calculates 
to 3.3G.  I think I had tried only 1G last time, because I read in another bug 
about the suggestion to make small root partition and put the rest of the space 
for /home to make reinstalls easier in the future.

As a future design it might make more sense to let the installer select the 
package set, do the package conflict resolution and size calculations, and then 
go to the disk management screens as you will then know the exact install size 
and can prevent a disk layout that won't allow the install to proceed.

Note You need to log in before you can comment on or make changes to this bug.