Bug 179684 - groff depends on X11-libraries
groff depends on X11-libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: groff (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 19:52 EST by Roy-Magne Mo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 07:55:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy-Magne Mo 2006-02-01 19:52:50 EST
Description of problem:
gxditview included in groff-package depends on X11-library.

Version-Release number of selected component (if applicable):
groff-1.18.1.1-8

How reproducible:
always

Steps to Reproduce:
1. 
# rpm -q --requires groff|grep X11
libX11.so.6

# ldd /usr/bin/gxditview
        linux-gate.so.1 =>  (0x00ded000)
        libXaw.so.7 => /usr/lib/libXaw.so.7 (0x001b5000)
        libXmu.so.6 => /usr/lib/libXmu.so.6 (0x009bd000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0x00acf000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x002e7000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x00b34000)
        libXpm.so.4 => /usr/lib/libXpm.so.4 (0x006cf000)
        libXp.so.6 => /usr/lib/libXp.so.6 (0x0026a000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x005d5000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x007e2000)
        libm.so.6 => /lib/i686/nosegneg/libm.so.6 (0x00111000)
        libc.so.6 => /lib/i686/nosegneg/libc.so.6 (0x002f0000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00ee5000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00170000)
        libdl.so.2 => /lib/libdl.so.2 (0x00f61000)
        /lib/ld-linux.so.2 (0x00bb1000)


2.
3.
  
Actual results:
groff pulls in X when installing with yum

Expected results:


Additional info:
Comment 1 Roy-Magne Mo 2006-02-01 20:07:45 EST
How about splitting into it's own-package? nroff-X11 or something? 
Comment 2 Miroslav Lichvar 2006-02-02 07:55:49 EST
Thanks for reporting that. gxditview accidentaly slipped to the groff package,
where it doesn't belong, but it has own package groff-gxditview. It is fixed in
rawhide now.

Note You need to log in before you can comment on or make changes to this bug.