This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 179685 - /etc/filestarter/non-routables contains routable networks
/etc/filestarter/non-routables contains routable networks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firestarter (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Michael A. Peters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 20:00 EST by dvd
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 08:36:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dvd 2006-02-01 20:00:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
The following networks that appear in /etc/firestarter/non-routables appear to be routable now:

74.0.0.0/8
125.0.0.0/8
126.0.0.0/8

Version-Release number of selected component (if applicable):
firestarter-1.0.3-8.fc5

How reproducible:
Always

Steps to Reproduce:
1. Launch firestarter gui
2. click Preferences
3. click Advanced Options
4. click "Block traffic from reserved addresses on public interfaces"
5. click Accept
6. Enable the firewall
  

Actual Results:  # iptables -L NR
contains the following entries:

hain NR (1 references)
target     prot opt source               destination
LSI        all  --  h-74-0-0-0.dllatx37.covad.net/8  xx.yy.zz.0/24
LSI        all  --  ppp-net.infoweb.ne.jp/8  xx.yy.zz.0/24
LSI        all  --  softbank126000000000.bbtec.net/8  xx.yy.zz.0/24


Expected Results:  no routable networks should be present

Additional info:

environment: FC5test2 (4.91) x86_64
Comment 1 Michael A. Peters 2006-02-02 07:46:48 EST
from
http://www.iana.org/assignments/ipv4-address-space

it looks like those might not be the only ones.

Note You need to log in before you can comment on or make changes to this bug.