Bug 179721 - No documentation for (RHN) up2date XMLRPC API methods
No documentation for (RHN) up2date XMLRPC API methods
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
550
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 09:32 EST by Dag Wieers
Modified: 2012-08-13 11:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 11:05:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2006-02-02 09:32:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
I am automating part of the system management (patch management) requirements we have on RHEL4 (and 3 and 2.1). But we lack proper documentation of the XMLRPC methods that the up2date client is using.

There is RHN XMLRPC documentation available from:

    https://rhn.redhat.com/rpc/api/

but this seems to lack specific calls that up2date is able to make. (server.up2date.method calls) There is also no system.listMethods() or system.methodHelp() method defined to query what is available.

Specifically I am now looking to get a list of all the available channels a system has access to (without providing a RHN username/password, just the systemid file). I only seem to get channel information about the already subscribed channels.

This is very annoying as there also seems to be a problem with stale logininfo when making different logons for different systemids in a single python-application. Somehow the logininfo global variable (yuck) is getting polluted along the way and for a RHEL4 subscribed system it returns RHEL3 channel information.

Also the XMLRPC API seems to have a subscribeChannel method, but no unsubscribeChannel method (at least I cannot find it). A list of methods, or a little documentation would be very useful to integrate existing software with RHN.

Any help/feedback/pointers are welcome.

Version-Release number of selected component (if applicable):
up2date-4.4.50-4

How reproducible:
Always

Steps to Reproduce:
1.1
2.2
3.3
  

Actual Results:    

Expected Results:    

Additional info:
Comment 1 Red Hat Bugzilla 2007-04-11 20:29:58 EDT
User bnackash@redhat.com's account has been closed
Comment 3 Jan Pazdziora 2012-08-13 11:05:05 EDT
Hello Dag, the XMLRPC API used by up2date/yum-rhn-plugin/rhnreg_ks/etc is not really meant as public interface to RHN/Satellite/Spacewalk. We basically assume that the only code using these API calls are the RHN client tools packages that are provided in the Red Hat Enterprise Linux channels and in the RHN Tools channels. That makes it possible to control the life of those XMLRPC calls, retire the old ones when old RHEL versions go out of support, without having to maintain the backward compatibility indefinitely.

Having said that, now that Satellite sources are available in the Spacewalk project, the XMLRPC calls can be found in its backend/ source directory.

I'm going to close this bugzilla now. While we won't be releasing the official documentation, you can use the Spacewalk project as the reference of the calls available. Please reopen if you disagree.

Note You need to log in before you can comment on or make changes to this bug.