Bug 179729 - Slab corruption in Devel Kernel
Slab corruption in Devel Kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 09:56 EST by Daniel Walsh
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 22:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Slab.txt (2.71 KB, text/plain)
2006-02-02 09:56 EST, Daniel Walsh
no flags Details
logfile segment showing kernel oops, then slab corruption detail (18.79 KB, text/plain)
2006-02-26 14:33 EST, pinter
no flags Details
logfile segment showing 'Drive appears confused', then slab corruption (5.34 KB, text/plain)
2006-03-10 13:18 EST, pinter
no flags Details
logfile segment showing 'Drive appears confused', *no* slab corruption (30.87 KB, text/plain)
2006-03-10 22:15 EST, pinter
no flags Details

  None (edit)
Description Daniel Walsh 2006-02-02 09:56:59 EST
Description of problem:
Slab corruption

Version-Release number of selected component (if applicable):
2.6.15-1.1884_FC5

How reproducible:
Don't know
Comment 1 Daniel Walsh 2006-02-02 09:56:59 EST
Created attachment 124049 [details]
Slab.txt
Comment 2 pinter 2006-02-26 14:33:42 EST
Created attachment 125283 [details]
logfile segment showing kernel oops, then slab corruption detail

Not sure if what I'm seeing here is germane, but I'm freezing regularly on a
PIII 600MHz 512MB(ECC) with no discernable usage pattern to trigger it.

I've swapped memory sticks in place, moved IDE from ATA33 onboard to Maxtor
ATA133 PCI card, installed an Antec power supply and swapped out the DVDROM
drive with an LG-4167B trying to pin this down.

All FC5 kernels through 2.6.15-1.1977_FC5 exhibit the system hang symptom,
although it isn't always logged. When it is logged, I save the detail away.

I've attached a section of a recent log showing both a kernel oops ('Unable to
handle kernel paging request') followed shortly thereafter by a 'Slab
corruption: (Not tainted) start=d2f73130'.

Please let me know if there is anything I can do to help isolate this further.
Cheers,
/p2
Comment 3 Dave Jones 2006-02-27 02:31:47 EST
Has this reoccured recently ?  There have been a number of slab corruption
problems fixed recently.
Comment 4 pinter 2006-03-03 10:36:30 EST
Last freeze was March 1st, on kernel build 1977 (no log detail available).

I updated to build 1996 at that time, and so far everything is stable.

Here's hoping...
Comment 5 pinter 2006-03-10 13:18:23 EST
Created attachment 125951 [details]
logfile segment showing 'Drive appears confused', then slab corruption

Okay, I may have been dealing with two problems.

In the large, slab corruption issues seem to have cleared insofar as system
freezes have dropped markedly. When it does hang, and I get some log detail, it
appears related to IDE handling of my dvdrom.

As previously noted, I've replaced both the controller and the dvdrom unit
recently, but still no joy. I thought keeping a disc in the drive seemed to
help, but I'm not sure now.

When the machine hangs, comes back, then locks up hard all within a minute or
two, I usually get some log detail. Otherwise, it just freezes and I get
schmaltz.

I'm upgrading to kernel build 2038 now. Once booted, I'll attach the boot log
showing the irq map, if that helps. Otherwise let me know if there's anything
else needed.

Thanks!
Comment 6 pinter 2006-03-10 22:15:32 EST
Created attachment 125979 [details]
logfile segment showing 'Drive appears confused', *no* slab corruption

Some good news, I think.

Since upgrading to kernel build 2038 and stress testing the dvdrom burner for
~8 hours in every way possible locally, I cannot induce a freeze at all.

As the attached log shows, I still get those knarly 'Drive appears confused'
warnings, but no other slab corruption errors and the machine just hums along.

Cheers,
/p2
Comment 7 pinter 2006-03-17 13:06:30 EST
Regrettably, since that last post a week ago two system hangs have occurred
that, when logged, show the fargin 'Drive appears confused' warning as the last
gasp text recorded before hard lock.

I thought maybe it was VMware Server Beta build 22088, but it wasn't running
today at all. Only a NFS read of a 16GB vmware image to my backup server on OS
X. Gnome was running too, if it matters.

I'm on 2.6.15-1.2054_FC5.
Comment 8 pinter 2006-07-10 18:13:25 EDT
Have been running stable on a 2.6.17 kernel for a while now and although I still
get fist fulls of those 'drive appears confused' messages, the hard freezing
appears fixed despite all my attempts to stress the box.

Note You need to log in before you can comment on or make changes to this bug.