Bug 179745 - ruby-devel should require ruby
ruby-devel should require ruby
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 11:52 EST by Andreas Bierfert
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 21:45:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andreas Bierfert 2006-02-02 11:52:57 EST
While pushing a build of koffice for extras-devel added ruby-devel as a
BuildRequires but detection of ruby failed because ruby is not Required for
ruby-devel.

05:53 PM][awjb@alioth ~]$ rpm -q ruby
package ruby is not installed

[05:55 PM][awjb@alioth ~]$ sudo rpm -ihv
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/ruby-devel-1.8.4-2.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/ruby-libs-1.8.4-2.i386.rpm
Retrieving
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/ruby-devel-1.8.4-2.i386.rpm
Retrieving
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/ruby-libs-1.8.4-2.i386.rpm
warning: /var/tmp/rpm-xfer.PsdtXn: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
Preparing...                ########################################### [100%]
   1:ruby-libs              ########################################### [ 50%]
   2:ruby-devel             ########################################### [100%]
Comment 1 Akira TAGOH 2006-02-02 21:45:13 EST
Have you read a description of ruby-devel package? ruby-devel is to make an
extension library for Ruby and ruby package contains Ruby interpreter. basically
you don't necessarily need Ruby interpreter at all to build an extension library
itself which is written in C say. so you need BuildReq: ruby if you want to use
Ruby interpreter for the package anyway.

Note You need to log in before you can comment on or make changes to this bug.