Bug 179746 - Cannot refresh 2 bugs at the same time
Summary: Cannot refresh 2 bugs at the same time
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Igor Foox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-02 16:57 UTC by Igor Foox
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 21:05:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TestCase (2.79 KB, text/plain)
2006-02-02 19:43 UTC, Igor Foox
no flags Details

Description Igor Foox 2006-02-02 16:57:15 UTC
Description of problem:
The plugin cannot refresh 2 bugs at the same time from one bugzilla. Small 'x'
icons appear on the bugs and their information is not fetched.

Version-Release number of selected component (if applicable):
0.1.2

How reproducible:
Almost always. Sometimes doesn't happen in an unpredictable fasion.

Steps to Reproduce:
1.Make query with more than 1 result.
2.Select group of bugs, right click, hit Refresh.
3.While previous group still refreshin, select another group, right-click, hit
Refresh.
  
Actual results:
Red 'x' icons appear on all/some icons of the bugs that should be refreshed. No
info is fetched. Sometimes an error message pops up.

Expected results:
No erros, multiple bugs fetched simultaneously.

Additional info:

This seems to be happening in the HTTPConnection.ConnectingThread class in the
getStream() method.

Comment 1 Igor Foox 2006-02-02 17:04:27 UTC
Not reproducable with IBM jvm.

Comment 2 Igor Foox 2006-02-02 19:43:57 UTC
Created attachment 124070 [details]
TestCase

This might be more than one bug in a relaed area of code, but here's one path
through the code that breaks it.

Comment 3 Igor Foox 2006-02-02 19:46:47 UTC
Versions of related packages:
gcc-java-4.0.2-8.fc4.i386
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2.i386
libgcj-4.0.2-8.fc4.i386
eclipse-platform-3.1.1-1jpp_1fc.FC4.12.i386

Comment 4 Igor Foox 2006-02-02 19:49:20 UTC
Tom, could you take a look? Maybe you would be able to figure out where the
problem is occuring here.

Comment 5 Igor Foox 2006-02-02 20:17:45 UTC
I can't reproduce this with the lateset gcc from rawhide (4.1.0-0.18), so it may
be something that's fixed there.

Comment 6 Tom Tromey 2006-02-03 21:06:22 UTC
With 4.0 I see:

opsy. gij ConnectingThread
Opened connection to http://bugzilla.kernel.org/xml.cgi?id=2897
Opened connection to http://bugzilla.kernel.org/xml.cgi?id=2898
Exception in thread "Thread-2" java.lang.NullPointerException
   at gnu.java.net.LineInputStream.LineInputStream(java.io.InputStream,
java.lang.String) (/home/tromey/gnu/4.0/install/lib/libgcj.so.6.0.0)
   at gnu.java.net.LineInputStream.LineInputStream(java.io.InputStream)
(/home/tromey/gnu/4.0/install/lib/libgcj.so.6.0.0)
   at gnu.java.net.protocol.http.Request.dispatch()
(/home/tromey/gnu/4.0/install/lib/libgcj.so.6.0.0)
   at gnu.java.net.protocol.http.HTTPURLConnection.connect()
(/home/tromey/gnu/4.0/install/lib/libgcj.so.6.0.0)
   at ConnectingThread.run() (Unknown Source)
   at .GC_start_routine (/home/tromey/gnu/4.0/install/lib/libgcj.so.6.0.0)
   at .__clone (/lib/libc-2.3.5.so)
Connected to http://bugzilla.kernel.org/xml.cgi?id=2897


This sounds vaguely familiar, I think it is a known http protocol
handler bug that was fixed for 4.1.  I can't reproduce with my 4.1 gcj.

Unless you need this fixed in 4.0.x, I am going to stop looking at it now.
We could close it as fixed/rawhide, what do you think?


Comment 7 Igor Foox 2006-02-07 21:05:26 UTC
It's not very high-priority, so I'll close this as fixed/rawhide. If you happen
to have to have a lot of free time on your hands it'd be nice to be fix this ;-).



Note You need to log in before you can comment on or make changes to this bug.