Bug 179749 - unzip -l on a jar file gives error
unzip -l on a jar file gives error
Status: CLOSED DUPLICATE of bug 180078
Product: Fedora
Classification: Fedora
Component: unzip (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-02-02 12:12 EST by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-05 09:56:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
jar that exercises problem (99.17 KB, application/octet-stream)
2006-02-02 12:12 EST, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2006-02-02 12:12:09 EST
Description of problem:
unzip -l <jarfile> gives:
error:  zipfile probably corrupt

Version-Release number of selected component (if applicable):

How reproducible:
It depends.  It seems to happen more often than not and I haven't actually
noticed it *not* happening ...

Steps to Reproduce:
1. grab the attachment
2 [details]. unzip -l org.eclipse.equinox.preferences_1.0.0.v20051211.jar
Actual results:
<list of included stuff>
error:  zipfile probably corrupt

Expected results:
<list of included stuff>

Additional info:
This happens both before and after a /usr/sbin/setenforce 0.
Comment 1 Andrew Overholt 2006-02-02 12:12:10 EST
Created attachment 124059 [details]
jar that exercises problem
Comment 2 Caolan McNamara 2006-02-05 09:56:51 EST
I was looking into this as well. I've a patch in the other issue.

*** This bug has been marked as a duplicate of 180078 ***

Note You need to log in before you can comment on or make changes to this bug.