Bug 179757 - [PATCH] preserve aspect ratio of SVG images in gdmgreeter (originally from gdm 2.8)
[PATCH] preserve aspect ratio of SVG images in gdmgreeter (originally from gd...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 12:51 EST by wingc
Modified: 2012-04-20 14:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 14:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against gdm 2.6 that adds aspect ratio preservation for SVG images (originally from gdm 2.8) (3.96 KB, patch)
2006-02-02 12:51 EST, wingc
no flags Details | Diff

  None (edit)
Description wingc 2006-02-02 12:51:32 EST
Description of problem:

In gdm 2.8, when designing a gdmgreeter theme (XML file) you can specify 'scale'
for a height or width parameter of a SVG image. This keeps the aspect ratio of
the image correct while allowing the size to vary according to the display
resolution.

In gdm 2.6 the only way to do this is to always give images a fixed size in
pixels. It's not a huge deal but it's nice if you want a logo to vary according
to the size of the screen, without it being stretched on widescreen monitors, etc.

I pulled the patch out of gdm CVS and rediffed it against gdm 2.6. The patch is
attached if you have any interest in adding this. Upgrading to gdm 2.8 would
have the same result. The patch doesn't change the DTD of the XML file used for
a greeter theme, so there is no risk of becoming incompatible with existing themes.

Version-Release number of selected component (if applicable):

I am using gdm-2.6.0.5-7.rhel4.4 (from RHEL4 Update 2) plus this patch. Works
well here.

How reproducible:

always

Steps to Reproduce:
1. note that 'scale' parameter is not supported in gdm 2.6 because it first
appeared in gdm 2.8

Additional info:

See attached patch, which is the verbatim change that went into gdm 2.8 source
(just rediffed against gdm 2.6 + rh).

Or, if you want to pull it out of CVS yourself, it's the 'gdm2' module in GNOME
CVS, the log entry is:


2005-04-19  Brian Cameron  <brian.cameron@sun.com>

...
...
        * gui/greeter/greeter_geometry.c,
          gui/greeter/greeter_item.h,
          gui/greeter/greeter_parser.c, docs/C/gdm.xml:  Now
          support ratio scaling of SVG images.  Docs weren't
          provided with the patch so I added some.  Patch
          provided by.  Fixes bug 159524.  Patch provided by
          Vincent Untz <vincent@vuntz.net>.


Browse at:

http://cvs.gnome.org/viewcvs/gdm2/
Comment 1 wingc 2006-02-02 12:51:33 EST
Created attachment 124063 [details]
patch against gdm 2.6 that adds aspect ratio preservation for SVG images (originally from gdm 2.8)
Comment 2 Jake Kodak 2012-04-20 14:52:02 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. After consideration, Red Hat does not plan to incorporate the suggested capability in a future release of Red Hat Enterprise Linux. If you would like Red Hat to re-consider your feature request, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.