Bug 179764 - lspci returns errors "resource has a 64-bit address"
lspci returns errors "resource has a 64-bit address"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pciutils (Show other bugs)
4.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 13:29 EST by Daniel W. Ottey
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 08:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs (4.65 KB, application/octet-stream)
2006-02-02 13:31 EST, Daniel W. Ottey
no flags Details

  None (edit)
Description Daniel W. Ottey 2006-02-02 13:29:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
lspci returns error messages saying "resource has a 64-bit address, ignoring"

I do not know if this should be an error, since this is the x86_64 version, so yes I think it should have 64-bit addresses.

Version-Release number of selected component (if applicable):
pciutils-2.1.99.test8-3.1

How reproducible:
Always

Steps to Reproduce:
1.  Run lspci
2.
3.
  

Actual Results:  Error messages:

pcilib: Resource 0 in /sys/bus/pci/devices/0000:2c:1e.0/resource has a 64-bit address, ignoring
pcilib: Resource 0 in /sys/bus/pci/devices/0000:2c:1c.0/resource has a 64-bit address, ignoring
pcilib: Resource 0 in /sys/bus/pci/devices/0000:17:1e.0/resource has a 64-bit address, ignoring
pcilib: Resource 0 in /sys/bus/pci/devices/0000:17:1c.0/resource has a 64-bit address, ignoring
pcilib: Resource 0 in /sys/bus/pci/devices/0000:02:1e.0/resource has a 64-bit address, ignoring
pcilib: Resource 0 in /sys/bus/pci/devices/0000:02:1c.0/resource has a 64-bit address, ignoring
pcilib: Resource 5 in /sys/bus/pci/devices/0000:00:1f.1/resource has a 64-bit address, ignoring


Expected Results:  No errors

Additional info:
Comment 1 Daniel W. Ottey 2006-02-02 13:31:13 EST
Created attachment 124067 [details]
Logs
Comment 3 Darragh Bailey 2006-06-21 07:49:34 EDT
Seems that pcilib doesn't handle printing of resources with 64bit address'
correctly which is why it ignores them. This was fixed in version 2.2.0 of
pciutils, see linked patch

http://www.hu.kernel.org/pub/software/utils/pciutils/alpha/pciutils-2.1.99-test11-2.2.0.diff
Comment 4 Harald Hoyer 2006-06-21 08:48:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0244.html


Note You need to log in before you can comment on or make changes to this bug.