Bug 179837 - torrent search uses mozilla instead of firefox
torrent search uses mozilla instead of firefox
Status: CLOSED DUPLICATE of bug 173275
Product: Fedora
Classification: Fedora
Component: bittorrent (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 05:16 EST by François Kooman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 03:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François Kooman 2006-02-03 05:16:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
When using the search option in the bittorrent-gui it opens mozilla instead of firefox

Version-Release number of selected component (if applicable):
bittorrent-gui-4.2.2-2.fc5

How reproducible:
Always

Steps to Reproduce:
1. start bittorrent client
2. search for torrent

  

Actual Results:  it opens mozilla

Expected Results:  it should use firefox (mozilla deprecated >fc5)

Additional info:
Comment 1 Paul Howarth 2006-02-03 05:47:02 EST
This isn't a bittorrent-specific issue, because bittorrent uses the "webbrowser"
module from the python package in Fedora Core to bring up the browser. That
module has a hard-coded search order, and might not actually find firefox at all
since it seems to look for "mozilla-firefox" rather than just "firefox".

Possible solutions:

* Add a symlink: /usr/bin/mozilla-firefox -> firefox

* Raise a bug on python to get it to look for "firefox" instead of
"mozilla-firefox" in webbrowser.py

* Set the BROWSER environment variable to "firefox"

See http://python.active-venture.com/lib/module-webbrowser.html for more on the
webbrowser module.
Comment 2 Paul Howarth 2006-02-28 13:43:03 EST
I believe this is a duplicate of Bug 173275.
If it's OK with you I'll close it as such.
Comment 3 François Kooman 2006-03-01 03:46:16 EST
ok, thanks.
Comment 4 Paul Howarth 2006-03-01 03:53:00 EST

*** This bug has been marked as a duplicate of 173275 ***

Note You need to log in before you can comment on or make changes to this bug.