Bug 179840 - No sound at all
No sound at all
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 06:12 EST by Edgar Bertoti
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 05:03:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edgar Bertoti 2006-02-03 06:12:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
------- System Config Soundcard --------
Thu Feb  2 19:46:05 CET 2006

------- lspci --------
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:05.0 IDE interface: Silicon Integrated Systems [SiS] RAID bus controller 180 SATA/PATA  [SiS] (rev 01)
00:06.0 Ethernet controller: Linksys NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AS [Radeon 9550]
01:00.1 Display controller: ATI Technologies Inc RV350 ?? [Radeon 9550] (Secondary)

------- lsmod --------
Module                  Size  Used by
vfat                   13121  1 
fat                    51293  1 vfat
usb_storage            74505  1 
parport_pc             27909  1 
lp                     12937  0 
parport                35593  2 parport_pc,lp
autofs4                19653  2 
i2c_dev                 9921  0 
i2c_core               22081  1 i2c_dev
rfcomm                 38745  0 
l2cap                  25921  5 rfcomm
bluetooth              48069  4 rfcomm,l2cap
sunrpc                141437  1 
ipt_REJECT              5953  1 
ipt_state               1985  5 
ip_conntrack           51953  1 ipt_state
nfnetlink               6617  1 ip_conntrack
iptable_filter          3137  1 
ip_tables              20033  3 ipt_REJECT,ipt_state,iptable_filter
dm_mod                 57181  0 
video                  16197  0 
button                  6737  0 
battery                 9541  0 
ac                      4933  0 
ipv6                  249761  8 
ohci_hcd               22497  0 
ehci_hcd               34381  0 
shpchp                 93317  0 
snd_intel8x0           32929  0 
snd_ac97_codec         88637  1 snd_intel8x0
snd_ac97_bus            2497  1 snd_ac97_codec
snd_seq_dummy           3781  0 
snd_seq_oss            31809  0 
snd_seq_midi_event      7105  1 snd_seq_oss
snd_seq                49617  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          9037  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            50545  0 
snd_mixer_oss          17985  1 snd_pcm_oss
snd_pcm                87493  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              25029  2 snd_seq,snd_pcm
snd                    54437  9 snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9889  1 snd
snd_page_alloc         10697  2 snd_intel8x0,snd_pcm
tulip                  50913  0 
floppy                 61957  0 
ext3                  129993  3 
jbd                    57813  1 ext3
sata_sis                7873  0 
libata                 47437  1 sata_sis
sd_mod                 18625  2 
scsi_mod              135529  3 usb_storage,libata,sd_mod

------- /etc/modprobe.conf --------
alias eth0 tulip
alias scsi_hostadapter sata_sis
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0  
options snd-intel8x0 index=0  
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd

------- /etc/asound.conf --------
#Generated by system-config-soundcard, do not edit by hand
#HWCONF
#DEV 0
pcm.!default { type hw card 0 device 0 } 
ctl.!default { type hw card 0 }

------- aplay -l --------
aplay: device_list:221: no soundcards found...

------- amixer --------


------- /proc/asound/version --------
Advanced Linux Sound Architecture Driver Version 1.0.10rc1 (Mon Sep 12 08:13:09 2005 UTC).

------- /proc/asound/modules --------


------- /proc/asound/pcm --------


------- system-config-soundcard --------

/usr/share/system-config-soundcard/soundcard.py:174: DeprecationWarning: use gtk.ComboBox
  self.primarySubDeviceOptionMenu = gtk.OptionMenu()
Wrong card index 0...
ALSA lib pcm_hw.c:1305:(_snd_pcm_hw_open) Invalid value for card
aplay: main:544: audio open error: No such device
Read config:
card 0
device 0
HW 1
----------- Kudzu -------------
Desc:           Silicon Integrated Systems [SiS] Sound Controller
Driver:         snd-intel8x0
Device:         None

--------

Version-Release number of selected component (if applicable):
alsa-lib-1.0.10-3.FC4  system-config-soundcard-1.2.12-5.FC4

How reproducible:
Always

Steps to Reproduce:
1. Soundcard configuration - scsound.log attached above
2. 
3.
  

Actual Results:  No soundcard found, no sound

Expected Results:  Using one year old KNOPPIX (kernel 2.4, no Alsa) the soundcard works perfectly

Additional info:
Comment 1 Martin Stransky 2006-02-03 08:02:02 EST
Hm, it looks like your card ins't supported by ALSA. Could you check the latest
drivers? how-to is here:
http://people.redhat.com/stransky/alsa
Comment 2 Edgar Bertoti 2006-02-06 05:17:14 EST
I have installed:

alsa-driver-1.0.11rc2.tar.bz2
alsa-lib-1.0.11-1.rc2.FC4.src.rpm
alsa-utils-1.0.11-1.rc2.FC4.src.rpm

from your web site; nothing changed, the same problem exists.
If you need the corresponding scsound.log, I can send it,
but it is essentially the same as reported above.

Comment 3 Martin Stransky 2006-02-06 17:15:54 EST
Please check if you have the right version of drivers (in /proc/asound/version).
If you have there the 1.0.11rc2 your card isn't supported or you loaded wrong
driver. I'm going to update to 1.0.11.rc3 drivers on my ALSA page ...
Comment 4 Edgar Bertoti 2006-03-06 03:25:10 EST
alsa-driver-1.0.11rc3.tar.bz2 works fine,
so this bug is fixed and can be closed.
Thank you for all.

Note You need to log in before you can comment on or make changes to this bug.