Bug 17987 - "col" fails when input contains extended characters
"col" fails when input contains extended characters
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 22:25 EDT by Peter Fales
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-30 22:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Fales 2000-09-30 22:25:25 EDT
I suspect this is really a problem in my system configuration or
not understanding how wide characters are supposed to work.  (Perhaps
a problem in the upgrade from 6.2 to 7.0).  But, if I run the command
"man man" everything works fine - I get the man page.  If I run
"man man | col", I get the first few lines of the man page, then:

Error executing formatting or display command.
System command (cd /usr/share/man ; (echo -e ".pl 11i"; /bin/gunzip -c
/usr/share/man/man1/man.1.gz) | /usr/bin/gtbl | /usr/bin/groff -Tlatin1
-mandoc | /usr/bin/less -isr) exited with status 141.

It looks like "col" is treating the first character with ASCII value
greater than 128 as the WEOF character and exiting.
Comment 1 Bernhard Rosenkraenzer 2000-10-01 18:00:08 EDT
Works for me (col from util-linux-2.10m-12, man-1.5h1-10).
Feel free to re-open this if you have further information that can help
reproducing this.

Note You need to log in before you can comment on or make changes to this bug.