Bug 17988 - Startup of pcmcia service causes kernel panic on Toshiba 750CDM
Startup of pcmcia service causes kernel panic on Toshiba 750CDM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i586 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 17941 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 22:43 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 20:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-30 22:43:58 EDT
Hello,

I just attempted several installations of Red Hat 7.0 (from an ISO 
obtained from a sunsite mirror) and have encountered a kernel panic upon 
boot. When init attempts to start the pcmcia service, a couple of screens 
worth of numbers scroll by, ended with a kernel panic message. At this 
point the system halts, requiring the power to be cycled on the computer.

I booted the system in interactive mode and elected not to start the 
pcmcia service. I checked the message and boot logs located in /var/log, 
but did not locate any logging information regarding this issue. I then 
attempted to start the pcmcia service manually by 
typing /etc/init.d/pcmcia start, which resulted in the system resetting. 

The computer in question here is a Toshiba 750CDM with a Toshiba ToPIC97 
CardBus Controller. It has been running various flavors of Linux and BSD 
for some time with no problems.

If you think this is a bug, please let me know and I will be happy to 
provide you with whatever additional information you need to more 
accurately diagnose this.



Bernard J. Duffy
bduffy@nycap.rr.com
Comment 1 kenneth_porter 2000-10-01 01:15:59 EDT
This sounds like a problem in the pcmcia (or kernel) component, not initscripts. A check of the pcmcia initscript (rpm -qf /etc/rc.d/init.d/pcmcia) indicates 
that it's part of the kernel-pcmcia-cs sub-package of the kernel package, so I'd suggest changing the component designation on this bug entry to kernel.
Comment 2 Need Real Name 2000-10-01 12:17:55 EDT
I agree, just changed component to kernel here is some additional info.

Error message output:
{ Alot of garbage that scrolls too quickly to read }
60>] [<c01dab4c>] [<c010a0bd>]
       [<c01175c4>]
Code: 39 66 70 75 28 c7 43 4c 11 00 00 ff 83 c4 03 00 a1 74
Aiee, Killing interrupt handler
kernel panic: Attempted to kill the idle task
In interrupt handler - not syncing

Comment 3 Alan Cox 2000-10-01 17:48:32 EDT
*** Bug 17941 has been marked as a duplicate of this bug. ***
Comment 4 J. Patrick Graves 2000-10-01 22:17:10 EDT
I'm having the same problem with the pcmcia services on my laptop.  pcmcia 
services under kernel 2.2.12 (RedHat 6.2) were running without any problems 
before I upgraded to RedHat 7.

This occurs when I load the i82365 module after the pcmcia_core module.

The Oops message looks like the following:

Scheduling in interrupt
Unable to handle kernel NULL pointer dereferences at virtual address 00000000
current->tss.cr3 = 00101000, $cr3=00101000
*pde = 00000000
Oops: 0002
CPU: 0
EIP  0010:[<c01114d2>]
EFLAGS: 0010282
eax: 00000018 ebx: c3b50000 ecx: 00000005 edx: c76ae000
esi: 00000000 edi: 00000000 ebp: c3b50584 esp: c3b50570
ds: 0018 cs: 0018 ss: 0018
process insmod (pid: 1515, process nr: 36, stack page=c3b51000)
STACK: (a whole bunch on numbers)
CALL TRACE: (more numbers)
CODE: (more numbers)
Aiee, Killing interrupt handler

jpgraves@northavenue.net
Comment 5 Jason Costomiris 2000-10-04 18:26:47 EDT
I can confirm that this also occurred on a Toshiba 730CDT, which uses the
Topic95 controller.
Comment 6 J. Patrick Graves 2000-10-04 22:14:44 EDT
OK, I resolved my issue only after a recompile of the kernel, a recompile of the 
pcmcia modules and tools, and a manual install of the pcmcia modules and tools ( 
they did not install properly on a "make clean;make all;make install" from 
inside the pcmcia source directory)  I suppose that I had this problem because I 
did an upgrade rather than a clean install.
Comment 7 Need Real Name 2000-10-05 22:15:12 EDT
I was able to resolve this issue by recompiling as well.
Comment 8 Geoff Keating 2000-10-08 17:45:02 EDT
This also happened with a clean install on a Sony Vaio PCG-Z505JS.  Perhaps a
kernel packaging/build problem?
Comment 9 David Mills 2000-10-14 05:36:48 EDT
I have a Toshiba 470CDT and have tried rebuilding the kernel, modules and pcmcia
packages all to no avail.  Only if I disable PCMCIA start by editing
/etc/sysconfig/pcmcia will it not panic.

Any other suggestions?
Comment 10 Need Real Name 2000-10-18 11:34:19 EDT
Same here. I have a Ricoh RL5C475 controller in my laptop (AJP 3420)and after a 
kernel rebuild (tried cs-3.1.19 and cs-3.1.21) I still get a kernel panic. 
Editing '/etc/sysconfig/pcmcia' gives a clean boot OK, but I'm still without 
networking :-(
Comment 11 peterjn 2000-10-18 23:57:09 EDT
I'm seeing the same panic on initialization of PCMCIA problem with my AST280M
laptop (which has a RL5c475 CardBus bridge).  

After changing '/etc/sysconfig/pcmcia' to include 'PCIC_OPTS=irq_list=7,9',
everything seems to work fine.  It appears that PCMCIA was trying to use IRQ3
and 4, but I have two serial ports set to use these IRQs, too.
Comment 12 David Mills 2000-10-19 00:59:53 EDT
I tried peterjn's suggestion which didn't work as is but did work if I changed
the IRQ list to 9,10.  So I am now operational.
Comment 13 Need Real Name 2000-12-02 18:43:44 EST
Same exact experience with Panasonic CF-35 laptop.  Booting and skipping the 
pcmcia service allows me to boot and work the desktop.
Comment 14 Joe Hoffman 2000-12-07 16:02:46 EST
I've experienced this problem on a new Dell C800.  I've resolved it by using the
latest
version of the PCMCIA Card Services v3.1.22.  This can be obtained from 
http://pcmcia-cs.sourceforge.net/  but they do not maintain binary versions.   
A local copy 
of the kernel source code was required as there are some dependencies, but
otherwise following the PCMCIA_HOWTO build steps worked great for me.
Comment 15 Joe Hoffman 2000-12-10 17:18:19 EST
Sorry for the confusion in my previous posting, however here is an update.

Upon installing the new card services, my Dell C800 worked fine (as far as the
PCMCIA 
Card Services were concerned).  I went on to work on Screen resolutions problems
which were
giving me trouble above 800x600.  Upon getting things screwed up completely, I
decided to 
reinstall Redhat 7 from CD. After performing this and reinstalling the CS 3.1.22
stuff, my laptop 
now locks up when starting Card Services. (Previously it had a kernel panic,
then locked up).
I can no longer get it to work sucessfully with Card Services.

I have a few notes in the messages log if anyone is interested, however I'm
running out of time
to work this issue and have moved on.  I want to continue working it so any
help, suggestions
would be appreciated.   I'll work on it as time permits.

joe
Comment 16 Joe Hoffman 2000-12-11 23:52:35 EST
Update on my previous postings:
I now have an explaination as to my previous troubles with installing the new
PCMCIA-CS (v3.1.22) stuff.  When building the code, you must answer 'y' to the
question about "Include PnP BIOS Resource Checking". This will generate a
working Card Services stuff (at least for the Dell Latitude C800).

Details of this problem (and an X windows Problem on the same box) can be found
at 
http://www.intelopment.com/dell_c800/.

joe
Comment 17 Joe Hoffman 2000-12-11 23:55:00 EST
Update on my previous postings:
I now have an explaination as to my previous troubles with installing the new
PCMCIA-CS (v3.1.22) stuff.  When building the code, you must answer 'y' to the
question about "Include PnP BIOS Resource Checking". This will generate a
working Card Services stuff (at least for the Dell Latitude C800).

Details of this problem (and an X windows Problem on the same box) can be found
at 
http://www.intelopment.com/dell_c800/.

joe

Note You need to log in before you can comment on or make changes to this bug.