Bug 179880 - Kernel boot panics with too many open files
Kernel boot panics with too many open files
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 11:29 EST by Andrew Bond
Modified: 2013-08-05 21:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 17:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bond 2006-02-03 11:29:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The x86_64 RHEL4 U2 kernel boot panics claiming too many open files.  The server has 2 Qlogic hba ports and each port sees 128 luns.  Each lun has 8 linux partitions, with partition 8 being the largest at 50GB.  So the server sees 256 luns and 2048 partitions.

If the server is booted without the Qlogic driver in the initrd, and the driver is instead loaded after the system has booted, the system does not panic.  So the issue is only boot related and may be a limit in the initrd configuration.

The same boot panic does not happen if the system is booted using a 32-bit kernel such as i686.  So the problem appears to be specific to x86_64.

Here some of the kernel boot messages.

/dev/sddh8: open failed: Too many open files
/dev/sddx8: open failed: Too many open files
/dev/sden8: open failed: Too many open files
/dev/sdfd8: open failed: Too many open files
/dev/sdft8: open failed: Too many open files
/dev/sdgj8: open failed: Too many open files
/dev/sdgz8: open failed: Too many open files
/dev/sdhp8: open failed: Too many open files
/dev/sdif8: open failed: Too many open files
/dev/sdiv8: open failed: Too many open files Couldn't create temporary
archive name.
Volume group "VolGroup00" metadata archive failed.
Couldn't create temporary text file name.
Backup of volume group VolGroup00 metadata failed.
/proc/devices: fopen failed: Too many open files Is device-mapper driver
missing from kernel?
/dev/mapper/control: open failed: Too many open files Failure to
communicate with kernel device-mapper driver.
0 logical volume(s) in volume group "VolGroup00" now active
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-22.EL.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1. Boot RHEL4 U2 x86_64 kernel with 256 luns and 2048 partitions available
2.
3.
  

Actual Results:  Kernel panic

Additional info:
Comment 1 Jim Paradis 2006-02-10 16:23:41 EST
Would it be possible to provide a complete console capture of a failed boot? 
This might provide some clues or at least context.
Comment 2 Jim Paradis 2006-09-28 17:32:23 EDT
No response from reporter for over seven months; closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.