Bug 179899 - Graphical login screen fails to appear after booting after kernel-2.6.15-1.1830 update
Graphical login screen fails to appear after booting after kernel-2.6.15-1.18...
Status: CLOSED DUPLICATE of bug 179041
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 14:09 EST by Marc Thompson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 03:54:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Thompson 2006-02-03 14:09:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
Problem booting after kernel-2.6.15 update

I updated to the kernel-2.6.15-1.1830 today, and strange things have happened.

1) During the boot process, where it usually just says "uncompressing Linux kernel", instead I get a big long list of things that it's doing. Then it goes through activating storage, audio, network, etc., and then the usual activation of services.

2) But then, when it should show the login splash screen, it instead just shows a gray screen filled with closely spaced vertical lines.

I hard reboot, and try to use the previous kernel version (2.6.14-1.1656).

1) This time, it goes through the "uncompressing Linux kernel" bit quietly.
2) However, it again fails to show the login splash screen, showing instead the gray screen/vertical lines. Can't login to do anything.

I performed the kernel update using the 'yum update' command, and it should be noted that the following files below were also updated along with the kernel:

libselinux-1.23.11-1.1                        Fri 03 Feb 2006 11:16:33 AM CST
mozilla-nspr-1.7.12-1.5.2                     Fri 03 Feb 2006 11:16:58 AM CST
mozilla-nss-1.7.12-1.5.2                      Fri 03 Feb 2006 11:16:59 AM CST
kernel-smp-2.6.15-1.1830_FC4                  Fri 03 Feb 2006 11:17:02 AM CST
mozilla-1.7.12-1.5.2                          Fri 03 Feb 2006 11:17:25 AM CST
kernel-2.6.15-1.1830_FC4                      Fri 03 Feb 2006 11:17:38 AM CST
libselinux-devel-1.23.11-1.1                  Fri 03 Feb 2006 11:17:48 AM CST
kernel-doc-2.6.15-1.1830_FC4                  Fri 03 Feb 2006 11:17:49 AM CST
firefox-1.0.7-1.2.fc4                         Fri 03 Feb 2006 11:17:55 AM CST
udev-071-0.FC4.2                              Fri 03 Feb 2006 11:18:01 AM CST
vixie-cron-4.1-41.FC4                         Fri 03 Feb 2006 11:18:02 AM CST
selinux-policy-strict-1.27.1-2.18             Fri 03 Feb 2006 11:18:03 AM CST
selinux-policy-targeted-1.27.1-2.18           Fri 03 Feb 2006 11:18:04 AM CST
kernel-smp-devel-2.6.15-1.1830_FC4            Fri 03 Feb 2006 11:18:08 AM CST
arts-1.5.1-0.1.fc4                            Fri 03 Feb 2006 12:10:51 PM CST




Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1830

How reproducible:
Always

Steps to Reproduce:
1.reboot
2.
3.
  

Actual Results:  Blank gray screen w/ no graphical login appears after reboot.  As a temporary workaround, I can click CTRL-ALT-Backspace, and this brings up the graphical login screen which I can then use to log in.



Expected Results:  graphical login screen should have appeared, but instead a blank gray screen appears.

Additional info:
Comment 1 William H. Haller 2006-02-03 14:45:33 EST
Similar results on 2 of 3 systems here. Both which failed were Matrox 400 
running default drivers on Dell 420 platforms. Both had varied confetti colors 
on the graphical boot screen. Power off-reboot on CRT had similar problems. 
 
Additional info: Switching to console text screen and back also gives a 
graphical screen however all console text screens on the failing boxes now 
have narrow but widely spaced vertical bars across them and are shifted left 
slightly from normal. This is true for LCD and CRT monitors. 
 
Previous kernels now exhibit same problem. 
Comment 2 Dave Jones 2006-02-03 15:13:26 EST
iirc, someone on the fedora list mentioned that the module-init-tools update
currently in updates-testing fixes this problem. Could you grab that and confirm ?
Comment 3 Pedro Matiello 2006-02-03 15:36:18 EST
updating module-init-tools from updates-testing worked for me. everything seems
to be ok now. thanks.
Comment 4 Dave Jones 2006-02-03 16:30:35 EST
good to know. thanks for testing.
I'll reassign this to module-init-tools for tracking until that gets pushed live.
Comment 5 Marc Thompson 2006-02-03 17:26:55 EST
Along with Pedro Matiello, I can confirm that the update on module-init-tools
from updates-testing seems to have solved the problem for me.
Comment 6 Bert Hinrichs 2006-02-04 22:35:15 EST
I have the same problem from the same upgrade.  I have found that if you
ctrl-alt-f1 to the text screen then ctrl-alt-f7 back to the graphics screen it
"fixes" itself and you get the normal graphics login and can go on your merry
way.  Each reboot does cause this problem though.  I will try the
module-init-tools update too.

Thanks,

Bert
Comment 7 Tony Carter 2006-02-05 14:03:32 EST
Same problem here.  HW = 3Dfx Voodoo 4500 and Acer AL1715 (LCD).
CTRL+ALT+BACKSPACE restores login screen.
module-init-tools from updates-testing also fixed it.
Comment 8 Steve Strong 2006-02-05 20:50:18 EST
OK, so it sounds like the module-init-tools fixes the bug.  Great work!  How can
I track the progress of this -- I'd like to know when the new version of
module-init-tools makes it into the regular yum updates.

steve
Comment 9 Harald Hoyer 2006-02-06 03:54:32 EST

*** This bug has been marked as a duplicate of 179041 ***

Note You need to log in before you can comment on or make changes to this bug.