Bug 179929 - Screens of 'IN from bad port' messages with kernel-2.6.15-1.1830_FC4
Screens of 'IN from bad port' messages with kernel-2.6.15-1.1830_FC4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
powerpc Linux
medium Severity low
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 16:38 EST by Mace Moneta
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.16-1.2096_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 14:43:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg showing the messages (48.87 KB, text/plain)
2006-02-03 16:41 EST, Mace Moneta
no flags Details

  None (edit)
Description Mace Moneta 2006-02-03 16:38:36 EST
Description of problem:

On booting kernel-2.6.15-1.1830_FC4 on a G3 PowerBook Pismo, receive many
screens of:

IN from bad port 213 at c03f13dc
IN from bad port 213 at c03f1404
...
IN from bad port 213 at c03f1484
IN from bad port 213 at c03f14ac
...
IN from bad port 233 at c03f13dc
IN from bad port 233 at c03f1404
...
IN from bad port 233 at c03f1484
IN from bad port 233 at c03f14ac
...
IN from bad port 253 at c03f13dc
IN from bad port 253 at c03f1404
...
IN from bad port 253 at c03f1484
IN from bad port 253 at c03f14ac
...

Version-Release number of selected component (if applicable):

kernel-2.6.15-1.1830_FC4

How reproducible:

Always

Steps to Reproduce:
1.Boot kernel-2.6.15-1.1830_FC4
2.
3.
  
Actual results:

Many screens of messages

Expected results:

Normal boot

Additional info:
Comment 1 Mace Moneta 2006-02-03 16:41:42 EST
Created attachment 124131 [details]
Dmesg showing the messages
Comment 2 Dave Jones 2006-02-03 23:01:28 EST
this is probably a dupe of 178344

dwmw2 ?

Comment 3 David Woodhouse 2006-02-04 04:47:52 EST
This happens when undisciplined drivers go poking at non-existent I/O ports. We
take a machine check, we print a debugging message, and we recover. I don't know
which driver would be using those port numbers.

The messages are almost purely cosmetic, though, and shouldn't be visible unless
you boot with 'debug' on the command line.
Comment 4 Barry K. Nathan 2006-02-07 00:38:54 EST
I'm seeing this on rawhide (and the latest FC4 update kernel), on an iMac G3. I
also saw it a long time ago on a PowerMac G4 running Gentoo, with an unpatched
mainline kernel (probably 2.6.7 or so at that point in time).

I *think* this was the config option that caused it on the Gentoo system, but
I'm not completely sure:
CONFIG_SERIAL_8250=y

Unfortunately I'm hunting down another PPC-specific kernel bug at the moment
(one that's not just cosmetic), so I won't have time to double-check my
recollection for a while. (I haven't filed this other bug in bugzilla yet,
because I still need to figure out whether it's in mainline or just Fedora.)
Comment 5 David Woodhouse 2006-04-25 14:57:49 EDT
I fixed it for the 8250 driver a while ago. In the latest FC5 test kernel (2101
or so) I fixed it for i8042 too.

Note You need to log in before you can comment on or make changes to this bug.