Bug 17996 - Mylex AcceleRAID 352 not supported
Mylex AcceleRAID 352 not supported
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
http://www.dandelion.com/Linux/DAC960...
:
: 16816 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 02:17 EDT by Dan Browning
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 21:00:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Browning 2000-10-01 02:17:04 EDT
The Mylex AcceleRAID 352 RAID Controller is not supported during the 
install of RedHat 7.0.  (HW:  dual zeon 550, 1gb ram, 6xCheetah hotswap, 
C440GX MB).

After installing RH 7.0 to an IDE disk (temporarily), I 
browsed /usr/src/linux-2.2.16/drivers/block/DAC960.c and noticed that only 
version 2.2.5 was included, which is probably why only older DAC960's are 
supported (2.2.9 is the newest version).

What is the correct solution to this problem?  
 - I know that I can install to an IDE disk then cp -a -v the partition 
over to the DAC960 after building a new kernel.  That's messy (i.e. what 
if I didn't happen to have an IDE disk?).
 - I would like to build a driver disk for this (ala drivers.img) for use 
during installation, but the DAC960 requires some kernel patches to pci.c, 
which has kept me from making one so far.  (Unless it is still possible???)
 - How about loading a DAC960.o on the current box?  Is that plausible?
 - Move to 2.4.x. (but still doesn't help the during install problem).
Comment 1 Alan Cox 2000-10-01 18:08:09 EDT
The pci.h patches shouldnt affect the binary compatibility so you should be able
to build a matching
module for this.
Comment 2 Dan Browning 2000-10-04 01:34:05 EDT
Apparently, building DAC960.o from 2.2.16-22 (stock redhat version), 2.2.16 
from kernel.org, and 2.2.17: none work (even when compiled on a RH6.2 box).  
The resulting DAC960.o gives the following insmod errors...

Where should I go from here?  Is there a way to build my own BOOT.img for RH7.0 
with a custom 2.2.16 kernel (that includes mylex version 2.2.8)?  Do I need to 
use the RedHat kernel config (for installation)?  Is there a HOWTO on boot.img 
and driver.img creation?  Thanks so much for the help.  I hope this feedback is 
useful.


DAC960.o: unresolved symbol __generic_copy_from_user_Rsmp2gig116166aa
DAC960.o: unresolved symbol pci_read_config_word_Rsmp2gig8764d15f
DAC960.o: unresolved symbol request_region_Rsmp2gig6d32b2d7
DAC960.o: unresolved symbol set_blocksize_Rsmp2giga842722a
DAC960.o: unresolved symbol sprintf_Rsmp2gig3c2c5af5
DAC960.o: unresolved symbol free_pages_Rsmp2gig234535e0
DAC960.o: unresolved symbol proc_root_Rsmp2gig4802a936
DAC960.o: unresolved symbol blk_dev_Rsmp2gig3fc31bcd
DAC960.o: unresolved symbol get_super_Rsmp2gig44f0020b
DAC960.o: unresolved symbol block_write_Rsmp2gigc820d54f
DAC960.o: unresolved symbol simple_strtoul_Rsmp2gig20000329
DAC960.o: unresolved symbol free_irq_Rsmp2gigf20dabd8
DAC960.o: unresolved symbol blksize_size_Rsmp2gig2f30b4b6
DAC960.o: unresolved symbol del_timer_Rsmp2gig5811f067
DAC960.o: unresolved symbol __ioremap_Rsmp2gig9eac042a
DAC960.o: unresolved symbol jiffies_Rsmp2gig0da02d67
DAC960.o: unresolved symbol wait_for_request_Rsmp2gig4074253b
DAC960.o: unresolved symbol proc_unregister_Rsmp2gig1d3df9b8
DAC960.o: unresolved symbol waitqueue_lock_Rsmp2gigfcdc212d
DAC960.o: unresolved symbol printk_Rsmp2gig1b7d4074
DAC960.o: unresolved symbol invalidate_inodes_Rsmp2gig713f3b3c
DAC960.o: unresolved symbol register_reboot_notifier_Rsmp2gig1cc6719a
DAC960.o: unresolved symbol interruptible_sleep_on_timeout_Rsmp2gig44dbfdd2
DAC960.o: unresolved symbol __get_free_pages_Rsmp2gig5b3b8f78
DAC960.o: unresolved symbol __wake_up_Rsmp2gig983d74e1
DAC960.o: unresolved symbol max_sectors_Rsmp2gig6bf58e33
DAC960.o: unresolved symbol unregister_blkdev_Rsmp2gigeac1c4af
DAC960.o: unresolved symbol unregister_reboot_notifier_Rsmp2gig3980aac1
DAC960.o: unresolved symbol iounmap_Rsmp2gig5fb196d4
DAC960.o: unresolved symbol gendisk_head_Rsmp2gigdfc0151c
DAC960.o: unresolved symbol io_request_lock_Rsmp2gig08c39da6
DAC960.o: unresolved symbol pci_find_device_Rsmp2gig0ee75d4c
DAC960.o: unresolved symbol local_irq_count_Rsmp2gig549df3db
DAC960.o: unresolved symbol fsync_dev_Rsmp2gig8ea128e2
DAC960.o: unresolved symbol schedule_Rsmp2gig4292364c
DAC960.o: unresolved symbol add_blkdev_randomness_Rsmp2gigd9cb21d1
DAC960.o: unresolved symbol __invalidate_buffers_Rsmp2gig98f51538
DAC960.o: unresolved symbol __const_udelay_Rsmp2gigeae3dfd6
DAC960.o: unresolved symbol kmalloc_Rsmp2gig93d4cfe6
DAC960.o: unresolved symbol local_bh_count_Rsmp2gig6b2a225a
DAC960.o: unresolvedsymbol __generic_copy_to_user_Rsmp2gigd523fdd3
DAC960.o: unresolved symbol request_irq_Rsmp2gig0c60f2e0
DAC960.o: unresolved symbol register_blkdev_Rsmp2gig45972e5a
DAC960.o: unresolved symbol add_timer_Rsmp2gigbea990b2
DAC960.o: unresolved symbol read_ahead_Rsmp2gig0abb7b07
DAC960.o: unresolved symbol sync_dev_Rsmp2gigfc0b0f49
DAC960.o: unresolved symbol block_read_Rsmp2gig9b08de33
DAC960.o: unresolved symbol block_fsync_Rsmp2gig5033a0b3
DAC960.o: unresolved symbol panic_Rsmp2gig01075bf0
DAC960.o: unresolved symbol release_region_Rsmp2gig43bde9b1
DAC960.o: unresolved symbol resetup_one_dev_Rsmp2gig3ceab725
DAC960.o: unresolved symbol max_segments_Rsmp2gig93ed2585
DAC960.o: unresolved symbol blk_size_Rsmp2giga2e0a082
DAC960.o: unresolved symbol kfree_Rsmp2gig037a0cba
DAC960.o: unresolved symbol proc_register_Rsmp2gig6edd62c8
DAC960.o: unresolved symbol vsprintf_Rsmp2gig13d9cea7
Comment 3 Dan Browning 2000-10-05 01:19:35 EDT
The following is what I get from 'make modules' using DAC960 driver 2.2.8 and 
kernel 2.2.16-22, (CC=kgcc of course), all done on a RH7.0 box.  I even tried 
building a DAC960.o with the kernel.org 2.2.16 with 2.2.8 driver, then 
insmoding it on redhat 7.0, but that failed with similar errors of the last 
post I made above.  I was thinking I could build a new BOOT disk, but then I 
would need to modify the kernel-2.2.16-22smp.rpm to include my new DAC960.o.  
otherwise it would probably install to the HDD okay, but then it wouldn't 
boot.  Or, is there still some way of making a compatible module that I am just 
missing?

make -C  kernel CFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-
strict-aliasing -D__SMP__ -pipe -fno-strength-reduce -m486 -malign-loops=2 -
malign-jumps=2 -malign-functions=2 -DCPU=686 -DMODULE -DMODVERSIONS -
include /usr/src/linux/include/linux/modversions.h" MAKING_MODULES=1 modules
make[1]: Entering directory `/usr/src/linux-2.2.16/kernel'
make[1]: Nothing to be done for `modules'.
make[1]: Leaving directory `/usr/src/linux-2.2.16/kernel'
make -C  drivers CFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -
fno-strict-aliasing -D__SMP__ -pipe -fno-strength-reduce -m486 -malign-loops=2 -
malign-jumps=2 -malign-functions=2 -DCPU=686 -DMODULE -DMODVERSIONS -
include /usr/src/linux/include/linux/modversions.h" MAKING_MODULES=1 modules
make[1]: Entering directory `/usr/src/linux-2.2.16/drivers'
make -C block modules
make[2]: Entering directory `/usr/src/linux-2.2.16/drivers/block'
kgcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2 -fomit-
frame-pointer -fno-strict-aliasing -D__SMP__ -pipe -fno-strength-reduce -m486 -
malign-loops=2 -malign-jumps=2 -malign-functions=2 -DCPU=686 -DMODULE -
DMODVERSIONS -include /usr/src/linux/include/linux/modversions.h   -
DEXPORT_SYMTAB -c loop.c
In file included from loop.c:46:
/usr/src/linux/include/linux/module.h:145: `get_module_symbol_R_ver_str' 
declared as function returning a function
/usr/src/linux/include/linux/module.h:145: warning: parameter names (without 
types) in function declaration
{standard input}: Assembler messages:
{standard input}:9: Warning: Ignoring changed section attributes for .modinfo
make[2]: *** [loop.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.2.16/drivers/block'
make[1]: *** [_modsubdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.2.16/drivers'
make: *** [_mod_drivers] Error 2
Comment 4 Michael Fulbright 2000-10-24 11:56:35 EDT
*** Bug 16816 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.