Bug 179984 - f-spot crashes after yesterday's upgrade - fc5t2
f-spot crashes after yesterday's upgrade - fc5t2
Status: CLOSED DUPLICATE of bug 179983
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 03:09 EST by Igor Jagec
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 04:50:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Jagec 2006-02-04 03:09:34 EST
From Bugzilla Helper:
User-Agent: Opera/8.51 (X11; Linux i686; U; en)

Description of problem:
The program just crashes after yesterday's upgrade on FC5t2. Here's the output:
$ f-spot
Starting new FSpot server

Unhandled Exception: Mono.Data.SqliteClient.SqliteSyntaxException: file is 
encrypted or is not a database
in [0x0007f] Mono.Data.SqliteClient.SqliteCommand:GetNextStatement (IntPtr 
pzStart, System.IntPtr pzTail, System.IntPtr pStmt)
in [0x00022] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/Mono.
Data.SqliteClient/Mono.Data.SqliteClient/SqliteCommand.cs:459) Mono.Data.
SqliteClient.SqliteCommand:ExecuteReader (CommandBehavior behavior, Boolean 
want_results, System.Int32 rows_affected)
in [0x00005] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/Mono.
Data.SqliteClient/Mono.Data.SqliteClient/SqliteCommand.cs:435) Mono.Data.
SqliteClient.SqliteCommand:ExecuteReader (CommandBehavior behavior)
in [0x00002] (at /usr/src/build/687862-i386/BUILD/mono-1.1.13.2/mcs/class/Mono.
Data.SqliteClient/Mono.Data.SqliteClient/SqliteCommand.cs:429) Mono.Data.
SqliteClient.SqliteCommand:ExecuteReader ()
in <0x00092> TagStore:LoadAllTags ()
in <0x0005c> TagStore:.ctor (Mono.Data.SqliteClient.SqliteConnection connection, 
Boolean is_new)
in <0x000c7> Db:.ctor (System.String path, Boolean create_if_missing)
in <0x002f1> Driver:Main (System.String[] args)
[ijagec@munja ~]$ rpm -q f-spot
f-spot-0.1.8-2
[ijagec@munja ~]$ uname -m
i686


Version-Release number of selected component (if applicable):
f-spot-0.1.8-2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 David Bentley 2006-02-17 10:26:06 EST
Current version f-spot-0.1.8-3 still crashing in the same maner as of 17-2-06
Comment 2 Alexander Larsson 2006-02-20 04:50:41 EST

*** This bug has been marked as a duplicate of 179983 ***

Note You need to log in before you can comment on or make changes to this bug.