Bug 179989 - Corrupt gdm login screen using xorg radeon with Radeon 9250 AGP under x86_64
Corrupt gdm login screen using xorg radeon with Radeon 9250 AGP under x86_64
Status: CLOSED DUPLICATE of bug 179041
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 05:27 EST by Ben Caradoc-Davies
Modified: 2016-01-08 20:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 17:01:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Caradoc-Davies 2006-02-04 05:27:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
I upgraded to kernel-2.6.15-1.1830_FC4 and the initial gdm login screen is now corrupt. See workarounds below.

This bug did not occur in kernel-2.6.14-1.1656_FC4 (from which I upgraded).

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1830_FC4

How reproducible:
Always

Steps to Reproduce:
1. Turn computer on.


Actual Results:  Boot sequence is normal. The gdm login screen is corrupt. It is almost black with a few lines of static, and what may have been a corrupt cursor trying in vain to blink through the haze.

It is possible to get the correct login screen by switching to a virtual console and back. See workarounds below.

Expected Results:  A pretty Fedora gdm login screen should have enticed me supply my username and password.

Additional info:

I have a Legend Radeon 9250 (128 MB) AGP video card. I am using the "radeon" driver. No funny or fancy settings.

The mainboard is an Asus A8V Deluxe (KT800Pro chipset) with an Athlon64 3200+.

I am implicating the kernel radeon module because there have been some recent changes to it (new in 2.6.15) and the kernel is all that I changed.

See the Linux Kernel Mailing List thread "2.6.15-git breaks Xorg on em64t"
http://lkml.org/lkml/2006/1/16/91

Workaround #1:

The gdm login screen can be reset by pressing Ctrl-Alt-1 to switch to a virtual console, then Alt-7 to return to the X display. The gdm login is then displayed correctly. The only oddity is that virtual consoles are now 160x45, not the One True Resolution of 80x25. (This higher resolution can be seen during shutdown.)

Workaround #2:

As suggested in the LKML entry linked above, I disabled DRI by commenting out 'Load "dri"' in /etc/X11/xorg.conf. This fixed the problem, but also reduced glxgears framerate by a factor of four.  :-(
Comment 1 Ben Caradoc-Davies 2006-02-04 05:40:27 EST
And here is a snippet from /var/log/Xorg.0.log where xorg identifies the card:

(--) RADEON(0): Chipset: "ATI Radeon 9200PRO 5960 (AGP)" (ChipID = 0x5960)
(--) RADEON(0): Linear framebuffer at 0xe8000000
(--) RADEON(0): BIOS at 0xfbd00000
(--) RADEON(0): VideoRAM: 131072 kByte (64 bit DDR SDRAM)
Comment 2 Martin A. Boegelund 2006-02-04 15:36:32 EST
I can confirm this bug.
I recently upgraded a couple of packages, kernel being one of them. I had no
trouble with kernel-2.6.14-1.1656_FC4, trouble started after upgrade to
kernel-2.6.15-1.1830_FC4, amongst other packages.

I'm experiencing the same kind of distorted login screen, and after I restart X
(Ctrl-Alt-Backspace), the good old, nice-looking GDM greeter screen comes up.

I have also seen that the terminal screen (Ctrl-Alt-F1) has been distorted:
- Ctrl-Alt-F1
- Login as root
- Run Setup
- results in thin blue lines across the terminal screen, but screen output is
still kind of readable

I have not been able to reproduce this last thing, but I thought I'd better
mention it...

My video hardware is:
ASUS A7000/T - Graphic adapter - RADEON 7000 - AGP 4x - 64 MB DDR.
Comment 3 Ben Caradoc-Davies 2006-02-04 17:30:13 EST
(In reply to comment #2)
> I can confirm this bug.
[snip]
> My video hardware is:
> ASUS A7000/T - Graphic adapter - RADEON 7000 - AGP 4x - 64 MB DDR.

Martin, are you also using the "radeon" driver (in your xorg.conf "Device
section)? (This is the default, and is shipped with FC4.)

And what is your architecture? Are you using FC4 x86_64? There is an indication
in the LKML that this bug has only been seen in x86_64.

Does commenting out 'Load "dri"' in your xorg.conf "Module" section fix the bug?
Comment 4 Jan ONDREJ 2006-02-05 06:33:25 EST
I can confirm this on Sapphire Radeon 9200 on x86 (Athlon XP).

I am using swsusp2 kernel:
  kernel-2.6.15-1.1830_1.rhfc4.cubbi_swsusp2.i686.rpm

Another workaround is to rename radeon.ko to another name. After kernel update
you don't need to change anything to return to previous state. :)
Comment 5 Wolfgang Ocker 2006-02-05 06:42:27 EST
I can confirm this on a Compaq nx7010 (Centrino, Pentium M).

lspci says about the graphics controller:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL
9000] (rev 01)

I see the problem on the netdev (2.6.15-1.1830_FC4.netdev.9) and the standard
standard (2.6.15-1.1830_FC4) kernel.
Comment 6 Russell Davies 2006-02-05 21:04:22 EST
Also confirmed on the following two machines running KDE 3.5:

1) Acer 650 with ATI Mobility Radeon 7200 
2) Acer 800 with ATI mobility radeon 9000

Fresh install of FC4 sees everything working with kernel-2.6.11-1.1369_FC4.  Yum
upgrade to current repository (as of Feb 5th 2006) and including
kernel-2.6.15-1.1830_FC4, sees the bug reproduced. 

Login manager is corrupt, with vertical bars and oversized images and single
lines of desktop rendered over multiple lines of display.  By logging in blindly
through the currept login manager, it is revealed that the KDE desktop is
similarly corrupted. 

ctrl-alt-backspc causes problem to apparently clear when X restarts.  On closing
X, the console does not revert back to 80x25.  

Comment 7 Fred New 2006-02-06 05:03:24 EST
This looks like the problem introduced by the udev required by the 1830 kernel.
 Have a look at bug 179041.
Comment 8 Martin A. Boegelund 2006-02-06 07:09:36 EST
(In reply to comment #3)

> And what is your architecture? Are you using FC4 x86_64? There is an indication
> in the LKML that this bug has only been seen in x86_64.

Negative. I'm plain i386. I run a Celeron 2GHz.
Comment 9 Russell Davies 2006-02-06 08:34:56 EST
(In reply to comment #7)
> This looks like the problem introduced by the udev required by the 1830 kernel.
>  Have a look at bug 179041.

In response to comment #3, commenting out Load "dri" in xorg.conf worked for me
too.  

In response to comment #7, I've then re-enabled the 'Load "dri"' in xorg.conf,
and did a "yum --enablerepo=updates-testing
module-init-tools-3.2-0.pre9.0.FC4.1", (see comment #16 in 179041) followed by a
reboot, and this also solved the problem.  I agree that this looks like a
duplicate of 179041.
Comment 10 Russell Davies 2006-02-06 08:38:33 EST
(In reply to comment #8)
> (In reply to comment #3)
> 
> > And what is your architecture? Are you using FC4 x86_64? There is an indication
> > in the LKML that this bug has only been seen in x86_64.
> 
> Negative. I'm plain i386. I run a Celeron 2GHz.
> 


Likewise, IA32 for me too. 
Comment 11 Ben Caradoc-Davies 2006-02-06 18:12:59 EST
(In reply to comment #9)
> In response to comment #7, I've then re-enabled the 'Load "dri"' in xorg.conf,
> and did a "yum --enablerepo=updates-testing
> module-init-tools-3.2-0.pre9.0.FC4.1", (see comment #16 in 179041) followed by a
> reboot, and this also solved the problem.  I agree that this looks like a
> duplicate of 179041.

This morning I updated to module-init-tools-3.2-0.pre9.0.FC4.1 (from the
mainstream updates feed). I re-enabled 'Load "dri"' in xorg.conf and rebooted,
and the gdm greeter was displayed correctly, so I can confirm that this update
fixes the problem. (It blacklists the framebuffer modules to prevent
X/framebuffer conflicts.)
Comment 12 Dave Jones 2006-02-07 17:01:50 EST

*** This bug has been marked as a duplicate of 179041 ***

Note You need to log in before you can comment on or make changes to this bug.