Bug 179990 - yum - used all memory (and swap) - system down
yum - used all memory (and swap) - system down
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 05:42 EST by Maxim Prohorenko
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 11:45:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Prohorenko 2006-02-04 05:42:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.1 (like Gecko)

Description of problem:
When I use yum, pup or yumex than update proccess used all system memory and 
system don't ansver again.  

Version-Release number of selected component (if applicable):
yum-2.5.1-3 python-2.4.2-3 rpm-4.4.2-15

How reproducible:
Always

Steps to Reproduce:
1. $> yum update 
2. or $> yum info 
3. or $> pup 
   

Actual Results:  Loading "installonlyn" plugin 
Running "config" handler for "installonlyn" plugin 
Yum Version: 2.5.1 
COMMAND: yum -d 9 -e 9 
Installroot: / 
Ext Commands: 
   yum 
Setting up repositories 
developmen: #########################                          1/2Baseurl(s) 
for repo: ['http://mirrors.kernel.org/fedora/core/development/i386/', 
'http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/', 
'http://mirror.hiwaay.net/redhat/fedora/linux/core/development/i386/', 
'http://ftp.dulug.duke.edu/pub/fedora/linux/core/development/i386/', 
'http://mirrors.kernel.org/fedora/core/development/i386/', 
'http://sunsite.mff.cuni.cz/pub/fedora/development/i386/', 
'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/development/i386/'] 
development               100% |=========================| 1.1 kB    00:00 
extras-dev: ################################################## 2/2 
Baseurl(s) for repo: 
['http://download.fedora.redhat.com/pub/fedora/linux/extras/development/i386/', 
'http://mirrors.kernel.org/fedora/extras/development/i386/', 
'http://fedora.cat.pdx.edu/linux/extras/development/i386/', 
'http://fedora.gtlib.cc.gatech.edu/pub/fedora.redhat/linux/extras/development/i386/', 
'http://fr2.rpmfind.net/linux/fedora/extras/development/i386/', 
'http://fr.rpmfind.net/linux/fedora/extras/development/i386/', 
'http://ftp.chg.ru/pub/Linux/fedora/linux/extras/development/i386/', 
'http://ftp.kddilabs.jp/Linux/packages/fedora/extras/development/i386/', 
'http://ftp.lug.ro/fedora/linux/extras/development/i386/', 
'http://ftp-stud.fht-esslingen.de/pub/Mirrors/fedora.redhat.com/linux/extras/development/i386/', 
'http://ftp.uni-bayreuth.de/linux/fedora/linux/extras/development/i386/', 
'http://gd.tuwien.ac.at/opsys/linux/fedora/extras/development/i386/', 
'http://mirror.hiwaay.net/redhat/fedora/linux/extras/development/i386/', 
'http://mirror.switch.ch/ftp/mirror/fedora/linux/extras/development/i386/', 
'http://mirror.web-ster.com/fedora/extras/development/i386/', 
'http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/extras/development/i386/'] 
extras-development        100% |=========================| 1.1 kB    00:00 
Reading repository metadata in from local files 
Setting up Package Sacks 
 

Additional info:

20724 root      25   0  809m 800m 5112 R 99.1 39.5   0:55.14 yum 
20724 root      25   0  920m 918m                            yum
Comment 1 Maxim Prohorenko 2006-02-04 05:49:30 EST
[extras-development] 
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-extras 
name=Fedora Extras $releasever - Development Tree 
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-extras-devel 
enabled=1 
gpgcheck=0 
[development] 
name=Fedora Core $releasever - Development Tree 
baseurl=http://mirrors.kernel.org/fedora/core/development/i386/ 
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-core-rawhide 
enabled=1 
gpgcheck=0 
[fc up ex] 
name=updates-testing-ru 
mirrorlist=http://fedora.redhat.com/download/mirrors/updates-testing 
enabled=1 
gpgcheck=0 
 
Comment 2 Maxim Prohorenko 2006-02-04 06:15:20 EST
rpm -Uvh python-* rpm-python-4.4.2-15.i386.rpm --force

   1:python                 ########################################### [ 20%]
   2:python-elementtree     ########################################### [ 40%]
   3:python-sqlite          ########################################### [ 60%]
   4:python-urlgrabber      ########################################### [ 80%]
   5:rpm-python             ########################################### [100%]

I reinstall 5 rpms by the hand and fix this problem
Comment 3 Jeremy Katz 2006-02-06 11:45:08 EST
This was caused by the sqlite update exposing a bug in the python-sqlite
bindings.  Has been fixed since.

Note You need to log in before you can comment on or make changes to this bug.