Bug 179994 - system-config-soundcard-1.2.12-5.FC4 does not detect sound card
system-config-soundcard-1.2.12-5.FC4 does not detect sound card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 06:53 EST by Paul Stansell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 05:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My scsound.log file. (11.07 KB, text/plain)
2006-02-04 06:53 EST, Paul Stansell
no flags Details
My scsound.log (15.03 KB, text/plain)
2006-02-06 01:10 EST, Craig McCluskey
no flags Details
Tar archive of files you requested. (30.00 KB, application/x-tar)
2006-02-06 18:46 EST, Paul Stansell
no flags Details
A gzipped tar archive of the files requested (2.80 KB, application/octet-stream)
2006-02-07 11:30 EST, Craig McCluskey
no flags Details
My /root/scsound.log (4.37 KB, text/plain)
2006-02-14 12:18 EST, Norm Pierce
no flags Details
Results of kudzu -s -p -c AUDIO (753 bytes, text/plain)
2006-02-14 14:21 EST, Norm Pierce
no flags Details

  None (edit)
Description Paul Stansell 2006-02-04 06:53:10 EST
Description of problem:

Since installing system-config-soundcard-1.2.12-5.FC4 on my Dell Inspiron 5150 
it no longer detects my sound card.


Version-Release number of selected component (if applicable): ystem-config-
soundcard-1.2.12-5.FC4


How reproducible:  Every time.


Steps to Reproduce:
1.system-config-soundcard
2.click on Play test sound
3.try various of the GUI options.

  
Actual results: No sample sound was played.


Expected results: To hear the sound sample.


Additional info: My /root/scsound.log which is attached.
Comment 1 Paul Stansell 2006-02-04 06:53:10 EST
Created attachment 124157 [details]
My scsound.log file.
Comment 2 Craig McCluskey 2006-02-06 01:09:04 EST
I have a Tyan S2469UGN with a Sound Blaster Audigy sound card running FC4.

I was listening to RealPlayer when I ran yumex to check for updates to my
system. One of the updates was system-config-soundcard-1.2.12-5.FC4. I thought,
"Hmmm ... I wonder what they changed with that." So I ran it.

When I closed the window, my sound stopped.

I have not been able to get the sound running since. I even went to the Alsa web
page and followed the instructions there. No success. Still no sound.

I am NOT a happy camper!
Comment 3 Craig McCluskey 2006-02-06 01:10:19 EST
Created attachment 124242 [details]
My scsound.log
Comment 4 Martin Stransky 2006-02-06 17:01:27 EST
Did you update the alsa-lib or alsa-utils package? Which version of these
packages do you have?
Comment 5 Martin Stransky 2006-02-06 17:39:35 EST
Could you please attach files /etc/security/console.handlers,
/etc/alsa/ainit.conf and all files from /etc/alsa/pcm?

Do you use your sound card as a common user or as root?

Comment 6 Paul Stansell 2006-02-06 18:37:43 EST
(In reply to comment #4)
> Did you update the alsa-lib or alsa-utils package? Which version of these
> packages do you have?

I am using the following versions of alsa: alsa-lib-1.0.10-27.rhfc4.at and
alsa-utils-1.0.10-19.rhfc4.at.
Comment 7 Paul Stansell 2006-02-06 18:46:56 EST
Created attachment 124295 [details]
Tar archive of files you requested.
Comment 8 Martin Stransky 2006-02-07 03:22:48 EST
(In reply to comment #6)
> I am using the following versions of alsa: alsa-lib-1.0.10-27.rhfc4.at and
> alsa-utils-1.0.10-19.rhfc4.at.

Please check the official and latest FC4 alsa-lib/alsa-utils packages.
Comment 9 Craig McCluskey 2006-02-07 11:30:24 EST
Created attachment 124323 [details]
A gzipped tar archive of the files requested
Comment 10 Craig McCluskey 2006-02-07 11:41:12 EST
I am using:

alsa-lib-1.0.10-3.FC4
alsa-lib-devel-1.0.10-3.FC4
alsa-tools-1.0.9-1.fc4
alsa-utils-1.0.10-1.FC4,

which are the ones yum said were current.

I usually use sound as a common user, but tried it as root with no sound output.
Even cat {some file} > /dev/dsp makes no sound.
Comment 11 Paul Stansell 2006-02-07 15:26:39 EST
(In reply to comment #8)
> Please check the official and latest FC4 alsa-lib/alsa-utils packages.

I did as you suggested and installed alsa-lib-1.0.10-3.FC4,
alsa-utils-1.0.10-1.FC4 and alsa-lib-devel-1.0.10-3.FC4 and this did fix the
problem.

Thanks very much for your help!
Comment 12 Paul Stansell 2006-02-07 15:28:19 EST
(In reply to comment #8)
> Please check the official and latest FC4 alsa-lib/alsa-utils packages.

I did as you suggested and installed alsa-lib-1.0.10-3.FC4,
alsa-utils-1.0.10-1.FC4 and alsa-lib-devel-1.0.10-3.FC4 and this fixed the problem.

Thanks very much for your help!
Comment 13 Norm Pierce 2006-02-10 15:29:33 EST
Here are a few things that I have run into that can cause problems
when configuring the sound card.

This is what I am currently using :

alsa-lib-1.0.10-3.FC4
alsa-utils-1.0.10-1.FC4
system-config-soundcard-1.2.12-5.FC4

1. Version 1.2.12-5.FC4 of s-c-s doesn't create /etc/asound.conf
   unless user tries to change one of the four defaults.  If the user
   is happy with the defaults (like when there is only one sound card)
   the defaults probably won't be touched.  (Later the user runs s-c-s
   again, starts clicking on stuff, but doesn't change anything, and
   suddenly it magically works!)

   By the way, this was a problem with the version of s-c-s shipped
   with FC4 (1.2.11-5) when multiple sound cards were detected, but
   when only one was detected it would create /etc/asound.conf and set
   "defaults.pcm.card 0".  (I'm assuming this was changed in the new
   version so that it wouldn't reinitialize the default to 0 each
   time.)

2. The "Default audio card" menu is populated in the order that
   soundcardBackend.probeCards() detects the cards.  But it sets
   "defaults.pcm.card" in /etc/asound.conf to the index of the item
   within the menu.  Unfortunately, this may not correspond to the
   driver for the card named in the menu.  (This is similar to the
   problem that Version 1.2.11-5 of s-c-s had in choosing the wrong
   driver for the sound test.  That problem has been corrected.)

3. If a card is detected that doesn't correspond to a driver found in
   /proc/asound/modules, playing the test sound will always send sound
   to card 0 (/dev/dsp), and so give a false positive result (assuming
   that /dev/dsp exists).

4. Lastly, a minor item, but one that can be confusing: When parsing
   the card description it is assumed that the first word, and only
   the first word, is the vendor name (unless there is a '|' in the
   description).  So, for instance, a CS 4610/11 from Cirrus Logic
   parses as "Vendor: Cirrus", "Model: Logic CS 4610/11. . .", and the
   description "CS 4236B - CSC0000" parses as "Vendor: CS 4236B",
   "Model: - CSC0000".  Perhaps the first word could continue to be
   used for the tab at the top of the box, but the unparsed
   description could be displayed in the body?

I do have sound working, so am in no hurry for any fixes, but I assume
you will want to look into these.

Comment 14 Grady Rhodes 2006-02-12 00:48:20 EST
I also had problems with sound after installing FC4 in Jan-2006, but I just got
around to looking into the sound problem last week.  I found a work around just now.

I have a Dell Dimension 8100 with a factory installed Turtle Beach, Santa Cruse
PCI sound card (CS4630 chip) which works with the CS46xx driver.

I am currently up2date on all installed modules. This includes the following
modules:
alsa-lib-1.0.10-3.FC4
alsa-utils-1.0.10-1.FC4
system-config-soundcard-1.2.12-5.FC4

The work around I found is:
1)
Open the Volume Control window (right click on speaker icon in far upper-right
corner of GNOME desktop).
2)
In the Volume Control window select: Edit -> Preferences
3)
In the pop-up window (Volume Control Preferences), check "IEC958 Input"
4)
In the Volume Control window a "Switches" folder tab should appear due to step 3 
(if it was not there already) -- Select Switches tab
5)
Check "IEC958 Input" and the sound should immedatly start working.

Unckecking this magic box does not stop the sound, but if it is not checked when
rebooting then the next time I booted, I did not have sound until I checked the
magic box again.

I hope this helps others just taking FC4 out for a test drive.  If anyone needs
furhter info to help isolate the problem in the code, then I will check back in
a week.

- former uc-lanl
Comment 15 Martin Stransky 2006-02-13 11:33:07 EST
(In reply to comment #13)
> 3. If a card is detected that doesn't correspond to a driver found in
>    /proc/asound/modules, playing the test sound will always send sound
>    to card 0 (/dev/dsp), and so give a false positive result (assuming
>    that /dev/dsp exists).
> 
> 4. Lastly, a minor item, but one that can be confusing: When parsing
>    the card description it is assumed that the first word, and only
>    the first word, is the vendor name (unless there is a '|' in the
>    description).  So, for instance, a CS 4610/11 from Cirrus Logic
>    parses as "Vendor: Cirrus", "Model: Logic CS 4610/11. . .", and the
>    description "CS 4236B - CSC0000" parses as "Vendor: CS 4236B",
>    "Model: - CSC0000".  Perhaps the first word could continue to be
>    used for the tab at the top of the box, but the unparsed
>    description could be displayed in the body?

If I understand well only those points are still unresolved, right? Could you
please attach your /root/scsound.log? (it should be created by s-c-s 1.2.12-5.FC4)
Comment 16 Martin Stransky 2006-02-13 11:39:11 EST
(In reply to comment #14)
> 5)
> Check "IEC958 Input" and the sound should immedatly start working.
> 
> Unckecking this magic box does not stop the sound, but if it is not checked when
> rebooting then the next time I booted, I did not have sound until I checked the
> magic box again.

Could you please check it with alsamixer? Can you attach output of amixer when
sound doesn't work (after boot) and when it works (checked/unchecked "IEC958
Input" by mixer)?
Comment 17 Martin Stransky 2006-02-13 11:43:34 EST
(In reply to comment #3)
> Created an attachment (id=124242) [edit]
> My scsound.log
 
Could you run s-c-s again, disable the "dynamic keys" and reboot your box?
What happens if you check "aplay /usr/share/sounds/phone.wav"?
Comment 18 Grady Rhodes 2006-02-13 23:35:25 EST
(In reply to comment #16)
> 
> Could you please check it with alsamixer? Can you attach output of amixer when
> sound doesn't work (after boot) and when it works (checked/unchecked "IEC958
> Input" by mixer)?

Rebooting when 'IEC958 Input' was previously unchecked:
Just after rebooting, and verifing no sound, the following command was issued by
a non-root user:

$ amixer -c 0 sget 'IEC958 Input'
Simple mixer control 'IEC958 Input',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

Now, with the check box checked (from the GUI version of the alsamixer (see
steps in comment #14) (GUI run by non-root user)) and sound immediatly working:

$ amixer -c 0 sget 'IEC958 Input'
Simple mixer control 'IEC958 Input',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

Finally, with the check box unchecked and sound still playing:

$ amixer -c 0 sget 'IEC958 Input'
Simple mixer control 'IEC958 Input',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]


A full listings of amixer output (`amixer -c 0') can be supplied (before check,
after check, & again unchecked) if needed.
Comment 19 Norm Pierce 2006-02-14 12:18:37 EST
Created attachment 124626 [details]
My /root/scsound.log

(In reply to comment #15)

All four items are unresolved in system-config-soundcard-1.2.12-5.FC4.
Sorry for my somewhat confusing description.  I have attached my
scsound.log as requested.  Here is some more detail on items 1 and 2:

1.  Unless the user clicks on the default audio card menu, the default
    PCM device menu, or either of the two check boxes at the bottom of
    the window, the /etc/asound.conf is not written.  This is fine as
    long as that file already exists (and matches the defaults shown
    by s-c-s), but firstboot could be trouble.

2.  Here are the audio devices and modules detected by s-c-s:

    o Cirrus Logic CS 4610/11 [CrystalClear SoundFusion Audio Accelerator]
      snd-cs46xx
    o CS4236B - CSC0001
      ns558
    o CS4236B - CSC0000
      snd-cs4236

    This is the order in which they appear, both in the tabbed box at
    the top of the window and in the default audio card menu.  When I
    choose the CS4236B - CSC0000 card to play the test sound, it
    works.  But if I choose it in the default audio card menu, it does
    not work because that card is card 1, but s-c-s sets
    /etc/asound.conf to:

	 defaults.pcm.card 2
	 defaults.pcm.device 0
	 defaults.ctl.card 2

    To get it to work, I must choose CS4236B - CSC0001.  That is
    because s-c-s always sets /etc/asound.conf for card 1 if the user
    chooses the second item in the menu, regardless of the location of
    the actual device.	(Imagine my amazement when I (supposedly) got
    sound from the ns558 module!)

    Could this be related to item 3?  If multiple cards are listed at
    position 0, then card 1 won't be the second card in the sorted
    list.
Comment 20 Norm Pierce 2006-02-14 14:21:48 EST
Created attachment 124635 [details]
Results of kudzu -s -p -c AUDIO

(Supplemental to comment #19)

I see that only the kudzu probe of the PCI bus is logged in
/root/scsound.log, so I thought that this attachment might be helpful,
as it shows where the ns558 driver is detected.
Comment 21 Martin Stransky 2006-07-25 05:11:47 EDT
Should be fixed in s-c-s-2.0.1.

Note You need to log in before you can comment on or make changes to this bug.