Bug 180000 - swt symlink is bad
swt symlink is bad
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 08:53 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 10:07:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-02-04 08:53:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
In the latest eclipse update /usr/share/java/swt-gtk-3.1.2.jar is a symlink to /usr/share/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_64.3.1.2.jar, which doesn't exist.  It's still a *3.1.1.jar file.

Also, can we install unversioned, or slightly less versioned swt-gtk symlinks in /usr/share/java?  I have to create new azureus and RSSOwl packages just because we went from 3.1.1 to 3.1.2.

Also, why is there no libswt3-gtk2 component listed in bugzilla?  I had to file this against eclipse-platform.

And, finally, what's the best way to request a specific swt version in my spec files?  libswt3-gtk2 = 3.1.2 doesn't work.



Version-Release number of selected component (if applicable):
libswt3-gtk2-3.1.2-1jpp_1fc

How reproducible:
Always

Steps to Reproduce:
1.ls -l /usr/share/java/swt*
2.
3.
  

Additional info:
Comment 1 Andrew Overholt 2006-02-06 11:00:33 EST
(In reply to comment #0)
> In the latest eclipse update /usr/share/java/swt-gtk-3.1.2.jar is a symlink 
> to /usr/share/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_64.3.1.2.jar,
> which doesn't exist.  It's still a *3.1.1.jar file.

Oops.  Sorry, I'll fix this along with a few other issues once gcc-4.1.0-0.23
hits the buildroot.

> Also, can we install unversioned, or slightly less versioned swt-gtk symlinks
in /usr/share/java?  I have to create new azureus and RSSOwl packages just
because we went from 3.1.1 to 3.1.2.

Yeah.  How about I add a generic swt-gtk.jar symlink?

> Also, why is there no libswt3-gtk2 component listed in bugzilla?  I had to 
> file this against eclipse-platform.

There is only one bugzilla component per SRPM.  SWT is part of our Eclipse SDK
build.

> And, finally, what's the best way to request a specific swt version in my 
> spec files?  libswt3-gtk2 = 3.1.2 doesn't work.

I don't know:

$ rpm -q --queryformat="%{version}\n" libswt3-gtk2
3.1.2
Comment 2 Andrew Overholt 2006-02-07 11:36:19 EST
eclipse-3.1.2-1jpp_4fc hit rawhide today.  It's got the following:

$ ls -lh /usr/share/java/*swt*
[...] /usr/share/java/swt-gtk-3.1.1.jar ->
/usr/share/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.1.1.jar
[...] /usr/share/java/swt-gtk.jar -> /usr/share/java/swt-gtk-3.1.1.jar

Is that good?  If so, please close RAWHIDE.  Thanks.
Comment 3 Ben Konrath 2006-02-07 13:46:17 EST
Wouldn't it be better to put in the link:

/usr/share/java/swt-gtk-3.1.jar ->  /usr/share/java/swt-gtk-3.1.1.jar

so that the jar is at least partially versioned?
Comment 4 Anthony Green 2006-02-08 00:08:58 EST
(In reply to comment #3)
> Wouldn't it be better to put in the link:
> 
> /usr/share/java/swt-gtk-3.1.jar ->  /usr/share/java/swt-gtk-3.1.1.jar
> 
> so that the jar is at least partially versioned?

I think I agree with Ben.  What do you think Andrew?
Comment 5 Andrew Overholt 2006-02-08 10:32:44 EST
(In reply to comment #4)
> (In reply to comment #3)
> > Wouldn't it be better to put in the link:
> > 
> > /usr/share/java/swt-gtk-3.1.jar ->  /usr/share/java/swt-gtk-3.1.1.jar
> > 
> > so that the jar is at least partially versioned?

How about:

/usr/share/java/swt-gtk-3.1.jar ->  /usr/share/java/swt-gtk-3.1.1.jar
/usr/share/java/swt-gtk.jar ->  /usr/share/java/swt-gtk-3.1.jar

Or is that too much?
Comment 6 Ben Konrath 2006-02-08 12:50:09 EST
(In reply to comment #5)
> How about:
> 
> /usr/share/java/swt-gtk-3.1.jar ->  /usr/share/java/swt-gtk-3.1.1.jar
> /usr/share/java/swt-gtk.jar ->  /usr/share/java/swt-gtk-3.1.jar

The problem with putting in an unversioned link is that eclipse components are
only forward compatible meaning that an application written for swt 3.1 may not
work with swt 3.0, but an application written for swt 3.0 will work on swt 3.1. 

The reason we want to remove the micro version with the link is becuase the API
will not change between point releases as these releases are used strictly for
bug fixes. So, I would say no unversioned link.

Comment 7 Andrew Overholt 2006-02-08 13:23:27 EST
(In reply to comment #6)
> (In reply to comment #5)
> > 
> > /usr/share/java/swt-gtk-3.1.jar ->  /usr/share/java/swt-gtk-3.1.1.jar
> > /usr/share/java/swt-gtk.jar ->  /usr/share/java/swt-gtk-3.1.jar
> [...]
> So, I would say no unversioned link.

Okay, we'll go with that.  I've committed it and it'll get picked up in the next
build.
Comment 8 Andrew Overholt 2006-02-13 10:56:49 EST
Are things as you'd like them now?
Comment 9 Andrew Overholt 2006-02-22 11:15:53 EST
Any thoughts here?

$ ls -lh /usr/share/java/*swt*
lrwxrwxrwx 1 root root 66 Feb 20 12:10 /usr/share/java/swt-gtk-3.1.1.jar ->
/usr/share/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.1.1.jar
lrwxrwxrwx 1 root root 33 Feb 20 12:10 /usr/share/java/swt-gtk-3.1.jar ->
/usr/share/java/swt-gtk-3.1.1.jar

... with libswt3-gtk2-3.1.2-1jpp_7fc
Comment 10 Anthony Green 2006-02-27 10:07:50 EST
(In reply to comment #9)
> Any thoughts here?

I think this is great.  I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.