Bug 180007 - Radeon X800XT not auto detected by system-config-display --reconfig
Radeon X800XT not auto detected by system-config-display --reconfig
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 11:08 EST by Chris Chabot
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 11:56:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log file (143.49 KB, text/plain)
2006-02-04 11:10 EST, Chris Chabot
no flags Details
xorg.conf file, modified for ati driver (2.51 KB, text/plain)
2006-02-04 11:12 EST, Chris Chabot
no flags Details

  None (edit)
Description Chris Chabot 2006-02-04 11:08:06 EST
ATI X800XT (Platinum) isn't detected by system-config-display (set to vesa
driver instead) but works perfectly with the ati driver.

lspci:

01:00.0 VGA compatible controller: ATI Technologies Inc R420 JP [Radeon X800XT]
01:00.1 Display controller: ATI Technologies Inc R420 [X800XT-PE] (Secondary)

from lspci -nvv:

01:00.0 0300: 1002:4a50
        Subsystem: 1043:003a
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 255 (2000ns min), Cache Line Size 04
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at d000 [size=256]
        Region 2: Memory at fbee0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at fbec0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans-
64bit- FW+ AGP3+ Rate=x4,x8
                Command: RQ=32 ArqSz=2 Cal=0 SBA+ AGP+ GART64- 64bit- FW+ Rate=x8
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

01:00.1 0380: 1002:4a70
        Subsystem: 1043:003b
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2000ns min), Cache Line Size 04
        Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at fbef0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Comment 1 Chris Chabot 2006-02-04 11:10:52 EST
Created attachment 124168 [details]
log file
Comment 2 Chris Chabot 2006-02-04 11:12:07 EST
Created attachment 124169 [details]
xorg.conf file, modified for ati driver
Comment 3 Mike A. Harris 2006-02-05 11:24:49 EST
This card is already listed in radeon.xinf as:

alias pcivideo:v00001002d00004A50sv*sd*bc*sc*i* radeon

This is the second card that has been reported to not autodetect, which has
turned out to already have an entry.  I suspect something might be wrong with
the parsing of the videoalias files.

CC'ing Bill/Jeremy for comment.
Comment 4 Chris Chabot 2006-02-05 12:27:11 EST
The bug has been set to NEEDINFO_REPORTER but i'm not sure what info is required
of me? :-)
Comment 5 Bill Nottingham 2006-02-06 12:39:58 EST
Please attach the output of 'kudzu -p -c video'.
Comment 6 Chris Chabot 2006-02-07 02:17:02 EST
Umm that might be a problem, kudzu doesn't currently seem to like my system:

[root@localhost ~]# kudzu -c -p video
Segmentation fault
[root@localhost ~]# kudzu -c -p video --safe
(no output)

Comment 7 Bill Nottingham 2006-02-07 11:22:53 EST
It's 'kudzu -p -c video'; you have the args reversed. Still, it shouldn't
segfault - can you attach a gdb backtrace of the segfault (after installing
kudzu-debuginfo)?
Comment 8 Chris Chabot 2006-02-08 02:06:34 EST
When i run kudzu thru gdb i get:

Program received signal SIGSEGV, Segmentation fault.
0x0016abd3 in strdup () from /lib/libc.so.6
(gdb) bt
#0  0x0016abd3 in strdup () from /lib/libc.so.6
#1  0x0805d28e in vbe_get_vbe_info () at vbe.c:165
#2  0x0805a35e in ddcProbe (probeClass=Variable "probeClass" is not available.
) at ddc.c:395
#3  0x08050366 in probeDevices (probeClass=CLASS_UNSPEC, probeBus=-9,
    probeFlags=1) at kudzu.c:806
#4  0x0804d054 in main (argc=Cannot access memory at address 0xffffffff
) at hwconf.c:938
#5  0x00116784 in __libc_start_main () from /lib/libc.so.6
#6  0x0804a491 in _start ()

Just to make sure i wasn't wasting anyone's time i yum upgrade'd to todays
recent tree and tried to reconfig using system-config-display again, and got the
same result still:
Section "Device"                                                               
                                             
        Identifier  "Videocard0"                                               
                                             
        Driver      "vesa"                                                     
                                             
        VendorName  "Videocard vendor"                                         
                                             
        BoardName   "ATI Technologies Inc R420 [X800XT-PE] (Secondary)"        
                                             
EndSection

As it was noted on the mailing list, it seems the (Secondary) thing confuses it,
it has a different pci_id, and there's no driver for it .. and it looks like its
trying to configure it, and not the main part, ie tries to configure 01:00.1 and
not 01:00.0 from lspci:
01:00.0 VGA compatible controller: ATI Technologies Inc R420 JP [Radeon X800XT]
01:00.1 Display controller: ATI Technologies Inc R420 [X800XT-PE] (Secondary)

Comment 9 Bill Nottingham 2006-02-08 10:51:46 EST
Ugh, that segfault implies garbage in the ddc return - not much that can be done
there.
Comment 10 Mike A. Harris 2006-02-08 11:26:42 EST
(In reply to comment #4)
> The bug has been set to NEEDINFO_REPORTER but i'm not sure what info is required
> of me? :-)

Sorry, lately I've been doing that by accident instead of NEEDINFO_ENG. ;)


(In reply to comment #9)
> Ugh, that segfault implies garbage in the ddc return - not much that can be
> done there.

Sanity checking to avoid SEGV? ;o)
Comment 11 Bill Nottingham 2006-02-08 11:30:30 EST
Hard to sanity check the pointer without dereferencing it.
Comment 12 Mike A. Harris 2006-02-08 11:53:58 EST
Changing component to 'kudzu'
Comment 13 Bill Nottingham 2006-02-08 11:56:41 EST
Closing as CANTFIX - garbage in, garbage out. :/

As for configuring the second device, that's handled in bug 176978.

Note You need to log in before you can comment on or make changes to this bug.