Bug 180019 - corrupted display with graphical greeter
corrupted display with graphical greeter
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
none
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 14:22 EST by jmw
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-19 17:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmw 2006-02-04 14:22:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.7.12-1.5.2

Description of problem:
i'm not certain this applies directly to the kernel, but could not find a more suitable choice in the list so i'm starting here.

my system was running under kernel 1656/1656SMP with nothing unusual to report, other than for Bug 169700 (badness in send_IPI_mask_bitmask on shutdown).  i updated to 1830/1830SMP, along with other updates for Mozilla and a few others i no longer recall.  update was done through Yum-Extender.

upon reboot into 1830SMP, everything appeared normal until the system got to the graphical greeter.  the greeter came up in a low-resolution mode, none of the horizontal traces were synchronized, i could make out the text of "fedora core" but it was badly oversized and horizontal lines were badly skewed.  i did a "blind" login -- entered user/password carefully -- i could see that the display changed slightly but was still unreadable and at a low resolution.  i entered CTRL-Alt-Del, "Enter" (forces a log-out), the greeter came up in normal display mode, i entered user/password and everything was displayed normally.

i tried several re-boots, and found the same problem and same re-login "fix".  i tried booting into 1656/1656SMP, and found the same problem.  this event did not happen with 1656/1656SMP prior to the update.  the problem always occurs at initial display of the graphical greeter, is always fixed through blind login and logout/re-login. 

on logout/shutdown, the display is completely blank.  prior to this update, logout/shutdown would return a textmode display of processes that were shut down, and so on.

i looked through DMESG and Log/Messages, but did not find any obvious error description.

this system is triple-boot, Grub controls the boot options.  the other two partitions are Win2K and WinNT, the OS for each of those behaves normally, there is no obvious display problem or other problem.

at this point, i'm lost -- i don't know what the system is doing just prior to display of the graphical greeter, i don't understand why display of that is fixed on a simple re-login, and why the problem recurs on re-boot.

Version-Release number of selected component (if applicable):
1656/1656SMP 1830/1830SMP

How reproducible:
Always

Steps to Reproduce:
1. "cold" or "warm" boot.
2. see normal text-mode messages on boot.
3. 
  

Actual Results:  when system gets to graphical greeter, display drops into low-resolution mode, horizontal synchronization is lost, cannot visually interpret anything on-screen.  mouse cursor appears normal.  apparently, system waits for user/password entry.  

Expected Results:  should display normal "Bluecurve" graphical greeter, with a dialog box for entry of username and password.

Additional info:

it appears the system is otherwise behaving normally.  once i start a logout/login sequence through CTRL-Alt-Del, i get a normal greeter and normal Gnome desktop.  the problem affects both "root" and "user" login.  this did not occur with 1656/1656SMP, but since updating to 1830/1830SMP it now occurrs with boot into either kernel.

i installed the same set of updates to a laptop PC, single processor, but don't find this problem with display of the graphical greeter.

up to now, i don't understand what is happening and why i can get around it through a second login.
Comment 1 jmw 2006-02-04 21:41:58 EST
it seems i have a work-around.  i now find that if i set a vga option in the
boot menu, the initial greeter login screen is displayed normally.  for now, i'm
using "vga=794".

i don't understand why this is needed now when no such option was needed
earlier, but it does appear to solve an annoying bootup problem.
Comment 2 Dave Jones 2006-02-18 22:54:10 EST
there were a few similar problems reported that went away when the latest
module-init-tools update was installed.  Can you check you have the latest ?
Comment 3 jmw 2006-02-19 17:48:05 EST
i believe i remember seeing at least one update for module-init-tools (or
similar) and 1831/1831SMP was also released.  after installing updates, i found
that a 'vga=' boot loader option was not needed, so it seems i am now back to
conditions prior to 1830/1930SMP. 

i prefer the smaller screen text size with vga=794, so i plan to continue using
that option.  meanwhile, it seems this bug report can be closed.

Note You need to log in before you can comment on or make changes to this bug.