Bug 180073 - Radeon 9800 Pro gets vesa driver instead of ati
Summary: Radeon 9800 Pro gets vesa driver instead of ati
Status: CLOSED DUPLICATE of bug 176978
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-05 12:23 UTC by David Bentley
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 20:43:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.59 KB, text/plain)
2006-02-05 12:25 UTC, David Bentley
no flags Details
xorg.0.log (47.33 KB, text/plain)
2006-02-05 12:27 UTC, David Bentley
no flags Details
xorg.conf (2.50 KB, text/plain)
2006-02-05 17:58 UTC, David Bentley
no flags Details
xorg.0.log (58.68 KB, text/plain)
2006-02-05 17:59 UTC, David Bentley
no flags Details
xorg.conf (2.50 KB, text/plain)
2006-02-06 20:36 UTC, David Bentley
no flags Details
xorg.0.log (60.34 KB, text/plain)
2006-02-06 20:37 UTC, David Bentley
no flags Details
video.txt (568 bytes, text/plain)
2006-02-06 20:37 UTC, David Bentley
no flags Details

Description David Bentley 2006-02-05 12:23:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
Tested as suggested in the post on the fedora-devel-list and the "vesa" driver gets used instead of the "ati" but as a result of the test the keyboard mapping also gets changed to "us".

hand edited the config file to use the "ati" driver and it all works OK.

the two attacments you requested will be added later.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7.3-2

How reproducible:
Always

Steps to Reproduce:
see description

Actual Results:  see description

Expected Results:  The use of the "ati" driver

Additional info:

Log files to be attached after bug has been filed.

Comment 1 David Bentley 2006-02-05 12:25:38 UTC
Created attachment 124204 [details]
xorg.conf

xorg.conf

Comment 2 David Bentley 2006-02-05 12:27:43 UTC
Created attachment 124205 [details]
xorg.0.log

xorg.0.log

Comment 3 Mike A. Harris 2006-02-05 16:12:26 UTC
Your video card PCI ID, from the X server log is:

(II) PCI: 01:00:0: chip 1002,4e48 card 1002,0002 rev 00 class 03,00,00 hdr 80

This is present in the radeon.xinf videoalias file in xorg-x11-drv-ati-6.5.7.3-2
already:

alias pcivideo:v00001002d00004E48sv*sd*bc*sc*i* radeon

Please ensure that your entire system is upgraded to the latest rawhide
packages of everything, and re-run system-config-display --reconfig
again.  It should generate a config that uses the "radeon" driver.

If it does not, then there might be a bug in kudzu perhaps.

Comment 4 David Bentley 2006-02-05 17:52:53 UTC
I actually included the wrong xorg.conf file (the one i re-edited back to ati so 
as you suggest I will have another go this time doing nothing before I post the 
files you ask ed for.

Comment 5 David Bentley 2006-02-05 17:58:54 UTC
Created attachment 124218 [details]
xorg.conf

Comment 6 David Bentley 2006-02-05 17:59:50 UTC
Created attachment 124219 [details]
xorg.0.log

Comment 7 David Bentley 2006-02-05 19:18:06 UTC
Note that the card shows up as ATI Technologies Inc Radeon [Radeon 9800 Pro]
(Secondary) in display settings and the following is not in the radeon.xinf file.

II) PCI: 01:00:1: chip 1002,4e68 card 1002,0003 rev 00 class 03,80,00 hdr 00

Comment 8 David Bentley 2006-02-05 19:48:26 UTC
See also https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176978

Wich is about the only video card in the system getting detected as
the second head.

Comment 9 David Bentley 2006-02-06 12:16:48 UTC
I have just seen that there is a new ati driver available in todays updates so
when I get home after work I will update the system before doing another test.

I will then update this bug with the result and if necessary add the attacments.

Comment 10 Bill Nottingham 2006-02-06 17:40:24 UTC
Please attach the output of 'kudzu -p -c video'

Comment 11 David Bentley 2006-02-06 20:36:07 UTC
Created attachment 124273 [details]
xorg.conf

Comment 12 David Bentley 2006-02-06 20:37:07 UTC
Created attachment 124274 [details]
xorg.0.log

Comment 13 David Bentley 2006-02-06 20:37:45 UTC
Created attachment 124275 [details]
video.txt

Comment 14 Bill Nottingham 2006-02-06 20:43:00 UTC
OK, so the probing data is right, but system-config-display is picking the
second head. Closing as a dup.

*** This bug has been marked as a duplicate of 176978 ***

Comment 15 Mike A. Harris 2006-02-06 22:55:21 UTC
The "secondary" PCI IDs, indicated by class 0380, are not used.  They are
for Microsoft Windows usage, and are unneeded by X.  Yes, this is confusing.


Note You need to log in before you can comment on or make changes to this bug.