Bug 180078 - Patch: unzip -l causing "zipfile probably corrupt (segmentation violation)"
Patch: unzip -l causing "zipfile probably corrupt (segmentation violation)"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: unzip (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
: 179749 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-05 09:50 EST by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 08:12:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replacement unzip-5.52-near-4GB.patch (10.83 KB, patch)
2006-02-05 09:53 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Caolan McNamara 2006-02-05 09:50:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Fedora/1.7.12-3

Description of problem:
unzip -l causing segv


Version-Release number of selected component (if applicable):
unzip-5.52-1

How reproducible:
Always

Steps to Reproduce:
touch one
zip one.zip one
unzip -l one.zip
Archive:  one.zip
  Length     Date   Time    Name
 --------    ----   ----    ----
        0  02-05-06 14:12   one
error:  zipfile probably corrupt (segmentation violation)

Additional info:
Comment 1 Caolan McNamara 2006-02-05 09:53:47 EST
Created attachment 124211 [details]
replacement unzip-5.52-near-4GB.patch

additional patch chunk appended to 4GB patch to fix this problem
Comment 2 Caolan McNamara 2006-02-05 09:57:04 EST
*** Bug 179749 has been marked as a duplicate of this bug. ***
Comment 3 Ivana Varekova 2006-02-06 08:12:35 EST
Thanks for your help, this problem is fixed in the last development version
(unzip-5.52-2).
Comment 4 Andrew Overholt 2006-02-06 14:07:53 EST
I have tried this version (unzip-5.52-2) and things work as expected.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.