Bug 18009 - printtool error
Summary: printtool error
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printtool   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-01 10:15 UTC by Neil Thompson
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 17:23:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neil Thompson 2000-10-01 10:15:20 UTC
Clean install of 7.0
printtool &
click on add
select local printer
click on ok
box comes back with info about detected ptinters
click on ok
printter data box comes back
click on input filter select
select Epson Stylus Color (UP)
Error box comes up 
click on Stack Trace

bad listbox index "": must be active, anchor, end, @x,y, or a number
    while executing
".sf.f6.list get $colindex"
    (procedure "LOCAL_select_filter" line 466)
    invoked from within
"LOCAL_select_filter .e.v10"
    invoked from within
".e.autofilter invoke"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke]"
    (procedure "tkButtonUp" line 7)
    invoked from within
"tkButtonUp .e.autofilter
"

dialog boxes for printtool no longer respond - have to kill top level
process

Comment 1 Crutcher Dunnavant 2000-10-02 19:13:13 UTC
I need more info, did you select anything in the filter page other than the
default for that printer?

I can not yet reproduce this problem on a clean system, so If you can give me
more info on how to reproduce.

Comment 2 Neil Thompson 2000-10-02 19:37:35 UTC
Eep!  Sorry, I left out a step, after 
select Epson Stylus Color (UP)
click on OK
then the Error box comes up

Sorry about that

Comment 3 pogosyan 2000-10-15 04:21:16 UTC
Yes I have reported the same bug in 17574 already for printtol-3.53
and it persits in 3.55.  
The problem is already in the fact that for Epson Stylus Color
printer no further choice choice appears in Color Depth/Uniprint mode
window.  With this window empty pressing OK crashes as reported.

			Dmitri Pogosyan

Comment 4 pogosyan 2000-10-15 05:10:27 UTC
O'K I found the problem, at least in my case.  printtool explicitely checks
existence of uniprint drivers as

/usr/share/ghostscript/*/$fname

If ghostscript is installed in different directory, this fails.
Alladin ghostscript, like 6.01, which I have installs in 
/usr/share/ghostscript/6.01/lib   and this 'lib' is all my problem.
I can imagine some people can have ghostscript in /usr/local.
It would be good if some less explicit way to check for uniprint drivers can
be found



Comment 5 Neil Thompson 2000-10-24 17:23:20 UTC
Please excuse the length of time replying to Dmitri's comments - I was away. 
Dmitri is correct.  It turns out theat the guy who cut me the 7.0 CDs was being
"helpful" and put the RH official updates on them as well as the Ghostscript
update.  Apart from the fact of printtool having hard-coded paths (bad idea
IMO), you can consider my problem fixed.


Note You need to log in before you can comment on or make changes to this bug.