Bug 180097 - s-c-ks still doesn't start
s-c-ks still doesn't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-05 13:57 EST by Richard Hally
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 10:06:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hally 2006-02-05 13:57:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
[root@localhost ~]# system-config-kickstart
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 82, in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 137, in __init__
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 118, in __init__
    self.y = sckYumBase()
  File "/usr/share/system-config-kickstart/packages.py", line 98, in __init__
    self.repos.enableRepo(self.getBaseRepoName())
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 189, in enableRepo
    thisrepo.enable()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 421, in enable
    self.baseurlSetup()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 550, in baseurlSetup
    self.check()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 431, in check
    raise Errors.RepoError, \
yum.Errors.RepoError: Cannot find a valid baseurl for repo: base
[root@localhost ~]# rpm -q system-config-kickstart
system-config-kickstart-2.6.4-1
[root@localhost ~]#



Version-Release number of selected component (if applicable):
error from trying to start varsion 2.6.4-1

How reproducible:
Always

Steps to Reproduce:
1.as root, enter system-config-kickstart at a prompt. 
2.
3.
  

Actual Results:  error reported (see above)

Expected Results:  don't know, it has never strted for me.

Additional info:

see also previous bug (178759) on previous version 2.6.3-1
Comment 1 Chris Lumens 2006-02-06 10:02:52 EST
Is this on FC4 or Rawhide?  Do you have any yum repos enabled in /etc/yum.repos.d?
Comment 2 Richard Hally 2006-02-06 14:11:05 EST
this is a FC5test2 install with all the updates from rawhide. the only repo I
have enabled is the fedora-devel.repo. it looks like this:
<snip comments>
# Reportable issues should be filed at bugzilla.redhat.com
# Product: Fedora Core
# Version: devel
name=Fedora Core $releasever - Development Tree
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/
#baseurl=http://mirror.hiwaay.net/redhat/fedora/linux/core/development/$basearch/
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-core-rawhide
enabled=1
gpgcheck=0
Comment 3 Chris Lumens 2006-02-06 15:25:17 EST
Does your fedora-devel.repo have "[development]" as the first line?  What are
the contents of /etc/redhat-release?
Comment 4 Richard Hally 2006-02-06 17:58:33 EST
yes, :

[root@localhost ~]# cat /etc/yum.repos.d/fedora-devel.repo
[development]
# These packages are untested and still under development. This
# repository is used for updates to test releases, and for
# development of new releases.
#
# This repository can see significant daily turn over and can see major
# functionality changes which cause unexpected problems with other
# development packages. Please use these packages if you want to work
# with the Fedora developers by testing these new development packages.
#
# fedora-test-list@redhat.com is available as a discussion forum for
# testing and troubleshooting for development packages in conjunction
# with new test releases.
#
# fedora-devel-list@redhat.com is available as a discussion forum for
# testing and troubleshooting for development packages in conjunction
# with developing new releases.
#
# Reportable issues should be filed at bugzilla.redhat.com
# Product: Fedora Core
# Version: devel
name=Fedora Core $releasever - Development Tree
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/
#baseurl=http://mirror.hiwaay.net/redhat/fedora/linux/core/development/$basearch/
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-core-rawhide
enabled=1
gpgcheck=0
[root@localhost ~]#
[root@localhost ~]# cat /etc/redhat-release
Fedora Core release 4.91 (Pre-FC5)
[root@localhost ~]#
Comment 5 Chris Lumens 2006-02-07 15:35:15 EST
Tomorrow's package should have more sane repo handling.
Comment 6 Richard Hally 2006-02-08 23:18:32 EST
system-config-kickstart-2.6.5-1 starts from a terminal window with the following
error:
[richard@localhost ~]$ system-config-kickstart
/usr/lib/python2.4/site-packages/pirut/GroupSelector.py:318: GtkWarning:
gtk_tree_view_scroll_to_point: assertion `GTK_WIDGET_REALIZED (tree_view)' failed
  tree.scroll_to_point(0, 0)

It starts and runs in spite of the above warning. However,
from the (Gnone) menu, it fails to start with a message box that says that the
file or directory does not exist: /usr/sbin/systme-config-kickstart.
It looks like the menu item needs to be updated to reflect the it is now in
/usr/bin not /usr/sbin.

Note You need to log in before you can comment on or make changes to this bug.