Bug 18014 - Microsoft PS/2 IntelliMouse doesn't work in graphical installer
Microsoft PS/2 IntelliMouse doesn't work in graphical installer
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 06:40 EDT by daniel.deimert
Modified: 2007-04-18 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 11:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel.deimert 2000-10-01 06:40:56 EDT
I have a Asus K7V motherboard and a Microsoft Intellimouse rev 1.1A.  When
the mouse is autoprobed in the graphical installer, it is detected as a
"Generic PS/2 mouse". However, it can't be used -- it appears to get
"stuck" on the top edge of the screen. Input to the mouse is accepted,
buttons can be pressed and opens menus, but it can't be moved vertically. 

This appears to be related to the autoprobing and handling of Intellimouse
in XFree 4, because when I did a text install and subsequently ran X, it
failed in the same fashion. However when I manually used the "setup" tool
to select a Microsoft Intellimouse rather than the Generic PS/2 mouse, it
works fine.

A related bug report is that it is impossible to select the mouse type
using the keyboard during graphical installation.
Comment 1 Michael Fulbright 2000-10-02 18:29:48 EDT
Is this a serial or PS/2 mouse?
Comment 2 Need Real Name 2000-10-03 02:18:09 EDT
I have a PS2 MS Intellimouse, same version, same problem.

Asus A7V, Duron 650. 

Worked under the "text install"

Comment 3 daniel.deimert 2000-10-03 03:21:00 EDT
It is a PS/2 Intellimouse.
Comment 4 Brent Fox 2000-10-09 15:42:25 EDT
This seems to be a problem with some Athlon and Duron motherboards.  At home, I
just built an Athlon system with an Abit KA7 motherboard and had the exact same
problem until I updated the BIOS on the motherboard.  Then everything was fine. 
I would check with Asus and find out if there is a BIOS update that addresses
this problem.  I spent a few minutes looking around the web, though, and I
didn't find anything really useful.  I did see a few messages in the newsgroups
from people who have experienced the same thing.
Comment 5 Charles Galpin 2000-10-10 11:14:28 EDT
I have an Asus K7M, Athlon 800, PS/2 intellimouse, and the same problem 
occurred. I also tried using the PC-98 selection for my PS2 PC-98 keyboard, but 
the characters were incorrectly mapped.
Comment 6 Brent Fox 2000-10-10 11:25:59 EDT
I forgot to mention that my mouse isn't a MS Intellimouse...it's a Logitech
cordless wheel mouse.  After I updated the BIOS, X Windows worked fine. 
However, if I am not running X Windows, moving the mouse causes the text cursor
to jump around in the top right corner of the screen.  As I'm moving the mouse,
it also is sending some kind of <Enter> signal, because the command prompt
starts scrolling down as if I were pressing <Enter> over and over again.
Comment 7 Brent Fox 2000-10-29 19:08:14 EST
The problem is that some mice cannot be correctly probed.  If they can't, the
installer uses the Generic - 3 Button Mouse (PS/2) setting.  However, on some
hardware configuration, (MS Intellimouse and Logitech cordless wheel mouse on
AMD Athlon systems, for example) this will cause the mouse pointer to get
"stuck" at the top of the screen.  I'd like to fix this problem, and I will look
into it, but I'm afraid that this problem is in the hardware.  There's something
weird about the way AMD Athlon (and Durons too, I assume) handle mouse input.  
A workaround is to make sure that you select Microsoft Intellimouse (PS/2),
(even if you have a wheel mouse of another brand) at the Mouse Selection window
in the installer.  If your mouse isn't working during the installer, you can
navigate the Mouse Selection screen by hitting the <ALT> key until the mouse
tree has the focus.  Then, you can use the arrow keys to move up and down in the
tree.  To expand a collapsed branch, use the "+" and "-" keys.  In fact, the
graphical installer can be navigated with the mouse.  I'll admit that this isn't
ideal.
Comment 8 Brent Fox 2000-10-30 22:08:46 EST
On the next to last sentence of the last post, I meant that the graphical
installer can be navigated without a mouse.

Note You need to log in before you can comment on or make changes to this bug.