Bug 180153 - RHEL4: emacs update overwrites site customization file default.el
RHEL4: emacs update overwrites site customization file default.el
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: emacs (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Jay Turner
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-02-06 06:06 EST by ritz
Modified: 2015-01-07 19:11 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0399
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2006-02-06 06:06:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
recent emacs update overwrites site-specific default init file in:
/usr/share/emacs/site-lisp/default.el

The emacs documentation explicitely says (Sect: 40.1.2):
" A site may have a default init file, which is the library named `default.el'. Emacs finds the `default.el' file through the standard search path for libraries (see section 15.1 How Programs Do Loading). The Emacs distribution does not come with this file; sites may provide one for local customizations."

recent update fails to conform to this documented behavior and contains the default.el file.


Version-Release number of selected component (if applicable):
emacs-21.3-19.EL.1

How reproducible:
Always

Steps to Reproduce:
1. install emacs-21.3-19.EL.1


Actual Results:  the site customization file is gone.

Expected Results:  the emacs distribution should not overwrite this file

Additional info:

traced to installation of emac-common package
Comment 6 Jens Petersen 2006-04-06 06:52:10 EDT
I just note here that the changelog entry for the fix in FC:

* Thu Feb 24 2005 Jens Petersen <petersen@redhat.com> - 21.3-24
- mark default.el as a noreplace config file (Pawel Salek, 149310)

is inaccurate since FC emacs is actually just using %config without noreplace.
Comment 7 Bob Johnson 2006-04-11 11:45:48 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 11 Red Hat Bugzilla 2006-08-10 17:31:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0399.html

Note You need to log in before you can comment on or make changes to this bug.