Bug 180154 - PATCH: fix digmid loading of timidity midi patches
PATCH: fix digmid loading of timidity midi patches
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: allegro (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 06:31 EST by Hans de Goede
Modified: 2013-07-02 19:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 07:52:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing digmid wavesynth (918 bytes, patch)
2006-02-06 06:31 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-02-06 06:31:05 EST
After my allgrorc fix to use timidity.cfg for the allegro digmid software
wavetable midi synth, the initialising of sound with midi works, but things are
still very quiet, this is because timidity.cfg contains absolute patch path's
and digmid can't handle these.

The attached patch fixes this, I'll also send it upstream.
Comment 1 Hans de Goede 2006-02-06 06:31:06 EST
Created attachment 124251 [details]
patch fixing digmid wavesynth
Comment 2 Jindrich Novy 2006-02-06 09:11:37 EST
Could you please write here a link to the upstream list where you send this fix
so that I can see the discussion? Thanks.
Comment 3 Hans de Goede 2006-02-06 14:26:53 EST
I send it to alleg-developers@lists.sourceforge.net, here is the reply I got:

On Mon, 2006-02-06 at 12:46 +0100, Hans de Goede wrote:
> > Hi all,
> > 
> > I'm working on the Linux port of Worminator3 an allegro using game and 
> > had some trouble to get midi sound to work.
> > 
> > Under most Linux distributions there is a softwavesynth called 
> > timidity++ which comes with a set of gus-patches, I choose to use this 
> > as patchset.
> > 
> > This made install_sound (from memory, more general sound-init) happy, 
> > however no midi songs could be heard, after some debugging I found out 
> > that digmid cannot handle patches.cfg files with absolute paths, the 
> > attached patch fixes this.

Thanks, committed it, with a small chage: Instead of increasing the path
size from 32 to 64, I increased it to 1024, which is what is used
throughout Allegro.

-- Elias Pschernig 
Comment 4 Jindrich Novy 2006-02-07 07:52:34 EST
Applied. Thanks.

Note You need to log in before you can comment on or make changes to this bug.