Bug 180175 - error on ENOSPC isn't particularly useful
error on ENOSPC isn't particularly useful
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
: 180174 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 11:40 EST by Bill Nottingham
Modified: 2014-03-16 22:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.4.3-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 16:12:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-02-06 11:40:34 EST
$ kinit
Password for notting@REDHAT.COM:
kinit(v5): Credentials cache I/O operation failed XXX when initializing cache

strace yielded that the disk was full when writing the cache file.

Version-Release number of selected component (if applicable):

krb5-libs-1.4.3-3
Comment 1 Bill Nottingham 2006-02-06 11:41:31 EST
*** Bug 180174 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2006-02-06 13:20:09 EST
Looking at the message , if it just replaced XXX with the errno or sterror, it
would be fine...
Comment 3 Nalin Dahyabhai 2006-02-06 13:22:36 EST
Yeah, my main question is whether or not that errno is still available when we
build the error text, because if it isn't, fixing this becomes much harder.
Comment 4 Nalin Dahyabhai 2006-02-06 16:12:19 EST
It looks as though errno isn't passed back, but remains unchanged.  Adding a
candidate patch to 1.4.3-4.

Note You need to log in before you can comment on or make changes to this bug.