Bug 180182 - fc4 will not boot from sdb - back to openfirmare
fc4 will not boot from sdb - back to openfirmare
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yaboot (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 12:54 EST by shrek-m
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 12:42:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fc4 pmg5 device-tree (512 bytes, text/plain)
2006-02-06 14:58 EST, shrek-m
no flags Details
device-tree.tar.gz (146.18 KB, application/x-tar)
2006-02-06 16:05 EST, shrek-m
no flags Details

  None (edit)
Description shrek-m 2006-02-06 12:54:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.7.12-1.3.1

Description of problem:
fc4 (and fc5t1) will not boot from sdb after installation from sdb.
if i boot into openfirmware i can select sdb but i always come back into openfirmware with ?scratched? macosx-linux-cd icons

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install fc on sdb
2. reboot
  

Actual Results:  only macosx (sda) or openfirmware is bootable

Additional info:

---- fc4-ppc-sdb-parted ----
Disk geometry for /dev/sdb: 0.000-239372.437 megabytes
Disk label type: mac
Minor    Start       End     Filesystem  Name                  Flags
1          0.000      0.031              Apple                 
2          0.031      1.031  hfs         untitled              boot
3          1.031    101.031  ext3        untitled              
4        101.031  10101.031  ext3        untitled              

---- e2labels ----
sdb3 = /boot
sdb4 = /

---- fc4-ppc-yaboot.conf ----
# yaboot.conf generated by anaconda

boot=/dev/sdb2
init-message=Welcome to Fedora Core\!
Hit <TAB> for boot options

partition=3
timeout=80
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
macosx=/dev/sda3
magicboot=/usr/lib/yaboot/ofboot

image=/vmlinuz-2.6.11-1.1369_FC4
	label=linux
	read-only
	initrd=/initrd-2.6.11-1.1369_FC4.img
	append="video=ofonly root=LABEL=/"
Comment 1 Paul Nasrat 2006-02-06 12:57:55 EST
nvsetenv boot-device

ofpath /dev/sdb3

Also can you grab a modified copy of ofpath from
http://people.redhat.com/pnasrat/ofpath and test that version too
Comment 2 Paul Nasrat 2006-02-06 13:07:51 EST
can you also mkdir /mnt/spare
mount -o ro -t hfs /dev/sdb2 /mnt/spare
grab ofboot.b off there and attach to this bug, then umount.  Also attaching
/proc/device-tree would help
Comment 3 shrek-m 2006-02-06 14:58:31 EST
Created attachment 124271 [details]
fc4 pmg5 device-tree

#1
nvsetenv, unknown word, HERE= ffa27b78
ofpath, unknown word, HERE= ffa27b78

rescue mode:
cp /mnt/usbdisk/ofpath /mnt/sysimage/sbin/ofpath
exit = reboot

still the same.
i can select the "linux-disk-icon" after booting with "alt"
yaboot gives me "l""x""c"...
l == back to openfirmware where i can select the "macosx" "linux" "cd" icons


#2
i can not mount sdb2 in rescue-mode == unknown device
i can not mount sdb2 in `chroot /nmnt/sysimage` == unknown filesystem "hfs"

`ls /proc/device-tree/` is this what you mean?
Comment 4 Paul Nasrat 2006-02-06 15:25:47 EST
nvsetenv and ofpath are commands within linux not within OF.

please execute ofpath in the chroot.

tar czvf /tmp/device-tree.tar.gz /proc/device-tree
Comment 5 shrek-m 2006-02-06 16:05:59 EST
Created attachment 124277 [details]
device-tree.tar.gz

device-tree.tar.gz

# nvsetup boot-device
boot-device=/k2-sata2@0/disk@0:2,\\:tbxi
# ofpath /dev/sdb3
/ht@0,f2000000,pci@5/k2-sata-root@c/k2-sata@1/disk@0:3
# exit


still the same problem.
Comment 6 Paul Nasrat 2006-02-06 16:33:00 EST
OK can you replace the original /sbin/ofpath with the newer copy from my people
page, ensure it is chmod 755. Then run ybin -v, and reboot.  Does that fix it?
Comment 7 shrek-m 2006-02-09 10:30:07 EST
a new rawhide http install 20060208 ~23:00 gmt (fc5t3-)
the same here, it is not bootable after the install.

your new "ofpath" and "ybin" are necessary, see the chronlogical steps.
1. rescue
ybin -v  == not bootable
2. rescue
your new ofpath == not bootable
3. rescue
ybin -v == is bootable

is the new ofpath in fc5t3 or is it to late?
Comment 8 Paul Nasrat 2006-02-09 10:35:01 EST
I'm trying to get data on if the patch is correct.  Your confirmation is
helpful, we should be able to get it into t3.
Comment 9 Paul Nasrat 2006-02-09 12:42:41 EST
Fixed in yaboot 1.3.13-0.17 

Note You need to log in before you can comment on or make changes to this bug.