Bug 18020 - Installation fails
Installation fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 09:28 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 06:08:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The error-file produced during installation. (720 bytes, text/plain)
2000-10-01 09:29 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-10-01 09:28:41 EDT
Installation on PII-400 with 2 disk drives, one used for windows, SCSI-card with som cd and scanner.

I dowloaded the iso-version of redhat 7. burned om cd. Created a boot disk from the cd.
Copied the /RedHat/* stuff onto the windows disk drive. (due to other errors, see 17840)
And started to install using the boot disk.
I've tried both, giving and not giving the win-disk a mount point and both custom install and workstation install.

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 360, in readCompsFile
TypeError: comp file version 3 or 4 expected
Local variables in innermost frame:
arch2: i686
Comment 1 Need Real Name 2000-10-01 09:29:35 EDT
Created attachment 3581 [details]
The error-file produced during installation.
Comment 2 Alan Cox 2000-10-01 18:00:43 EDT
This looks like an incorrect ISO but Im not 100% sure
Comment 3 Pekka Savola 2000-10-02 17:55:51 EDT
Did you edit RedHat/base/comps?  The beginning should be like:

---
4

1 Base {
[ ...]
---

The installer might crash with, for example, with DOS carriage return/line feed characters.
Comment 4 Michael Fulbright 2000-10-02 18:21:30 EDT
I agree - please make sure that the comps file was not changed when you copied
it.
Comment 5 Need Real Name 2000-10-03 06:08:44 EDT
I downloaded the iso using ftp from www.sunet.se (using Linux) and burned it directly. I haven't edit it at all.
It worked when I installed from the same cds on another machine. (from an IDE-cdromreader, no SCSI-card, and different graphics card etc)

> Did you edit RedHat/base/comps?  The beginning should be like:
no, and the beginning av that file on the cd looks like that...

Btw is there a md5sum from windows? (im stuck in that os right now)
Comment 6 Need Real Name 2000-10-03 06:13:12 EDT
Ah... the Base/Comps was chaged during the copy.... then that is the problem.

Note You need to log in before you can comment on or make changes to this bug.